Charger Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter #1
I emailed Tune Town about the availability of a wiring harness to integrate with the factory amp, thinking maybe they'd have better info than my installer, who wasn't able to find anything. Here is what he told me:

mounting kit 99-6507
Wiring harness 70-6502with out premium sound
With premium sound they have not test it yet to see if it works the part #is
70-6504 this part works on the magnum and the 300c but has not been tested
on the charger ,
The engineers say it should
Googling tells me these are Metra part numbers, though the 70-6504 for premium sound doesn't appear on their website. It does sound promising, though. Anyone who's looking to use the factory amp should ask their installer to get ahold of one of these parts and try it out, I know that's my next move.
 

·
Registered
Joined
·
153 Posts
Discussion Starter #2
Just got off the phone with my installer, they had tried the 70-6502 before, so they're ordering a 70-6504 and are going to try that. I'd say I'm cautiously optimistic at this point, it's certainly sounding more promising than before at least.
 

·
Registered
Joined
·
56 Posts
Are you replacing the speakers and head unit as well? What parts are you getting and what are their prices?
 

·
Registered
Joined
·
153 Posts
Discussion Starter #4
I'm keeping the speakers if at all possible. I have an empeg (RioCar) in-dash MP3 player that I want to put in. Ideally, the only parts I'd have to buy to do this would be a suitable wiring harness, the dash mounting kit, and some wires and what-not.
 

·
Registered
Joined
·
604 Posts
tonycpsu said:
I'm keeping the speakers if at all possible. I have an empeg (RioCar) in-dash MP3 player that I want to put in. Ideally, the only parts I'd have to buy to do this would be a suitable wiring harness, the dash mounting kit, and some wires and what-not.
nope. youll have to buy an amp too, unless youre going to wire all 4 6x9's to the rear channel on your HU
 

·
Registered
Joined
·
153 Posts
Discussion Starter #6
jamphat said:
nope. youll have to buy an amp too, unless youre going to wire all 4 6x9's to the rear channel on your HU
Why? If this wiring harness works, I can just use the factory amp with no changes to the speaker wiring, right?
 

·
Registered
Joined
·
604 Posts
tonycpsu said:
Why? If this wiring harness works, I can just use the factory amp with no changes to the speaker wiring, right?
oh, i skimmed your post and assumed the harness was supposed to interface with the steering wheel.

but a wiring harness is just that - a wiring harness, it wont be able to convert the ouput of your HU to the digital CAN Bus interface ... unless they plan on taking apart the amp and wiring it past the DAC's ...

if it works, great, i just highly doubt it...
 

·
Registered
Joined
·
153 Posts
Discussion Starter #8
Well, this guy says it definitely works on the premium sound in the Magnum and 300C, so that gives me more optimism than I had before. Maybe he's refering to an older system or something, but it's also interesting that the harness my own installer tried was a different number, and this one is slightly different, brand new (not on Metra's site) and my installer didn't have it in any catalog... That suggests that (maybe) they have something that works with the new Visteon amps.

Or so I hope. :)
 

·
Registered
Joined
·
604 Posts
tonycpsu said:
Well, this guy says it definitely works on the premium sound in the Magnum and 300C, so that gives me more optimism than I had before. Maybe he's refering to an older system or something, but it's also interesting that the harness my own installer tried was a different number, and this one is slightly different, brand new (not on Metra's site) and my installer didn't have it in any catalog... That suggests that (maybe) they have something that works with the new Visteon amps.

Or so I hope. :)
good luck...

but dont spend more than the factory amp is worth trying to tap into it ($150ish max?)
 
1 - 9 of 9 Posts
Top