Charger Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
507 Posts
Discussion Starter · #1 ·
so i just pickud up my car from the dealer this morning because the CEL was on and i wanted to get the codes read. come to find out the reason it was on (and still is) is because im getting errors from my radio. i put an after market deck in the car and basicaly the TCM and the PCM readings go thru the stock deck to the computer to read the codes. they told me that the computer wasnt recieving a signal from either the TCM or the PCM and that i need to put the stock deck back in if i want my car to run without errors.they even said that because its not getting a signal from either that my car might even shutoff while im driving. ??? :knockout:

i know many of you guys have after market stereos in your rides. has any of you recieved this error problem?
 

·
Registered
Joined
·
226 Posts
I had an aftermarket radio in my magnum and never got the light, sounds like crap to me. just my 2 cents though!!!
 

·
Registered
Joined
·
928 Posts
I have heard others get an error with after market navs in there. but to think your car would shut off while driving is a bit silly.
 

·
Registered
Joined
·
507 Posts
Discussion Starter · #4 ·
yea sounds like stupid bs too. another funny thing. i asked about getting the TCM reflashed because my car was feeling slugish and they said that they couldnt diagnose it because of the steroe throwing codes which might be why the car shifts funny. . :ninja:
 

·
Registered
Joined
·
1,606 Posts
I have a friend with a 2006 jeep cherokee and he added an aftermarket sound system.... The computer was throwing error at him because of the same reason... the stealer told him to go back to stock...... he did just to prove them wrong on how impossible it is for a sound system to trigger hal... and guess who was wrong?
the stock stereo (called a module) sends a signal to hal and if hal does not get the signal, you might get errors.... not as bad as shutting the car off while driving, but indeed some errors!
hope it helps
PS: he went back to aftermarket and now he drives all the time with hal on!
 

·
Registered
Joined
·
3,168 Posts
id just return that faceplate.. deck.. whatever... module... ?
and get a new one, different brand, or whatever.
 

·
Registered
Joined
·
277 Posts
I had a Sony HU and now I have the D3.......no problems with HAL.
 

·
Registered
Joined
·
5,193 Posts
HEY BUDDY-I'M A ASE AND A MECP ELECTRONICS TECH AND CAN TELL YOU THATS A BUNCH OF B.S!!!! NOTHING ON YOUR CAR HAS ANY THING TO DO WITH THE RADIO!!! the tcm/pcm and hal dont come any were around the radio circuit or the bcm. a bcm or radio problem [a.k.a can bus] will not throw a code what so ever. ask the dealer to show you the code that it's throwing.
 

·
Registered
Joined
·
1,019 Posts
nver heard such a thing from any car, but what do i know? did they charge u for the diagnostic test ?
 

·
Registered
Joined
·
507 Posts
Discussion Starter · #10 ·
no charge but they cant fix it because its an aftermarket deck.

here is a list of the codes it threw. not sure whats what so ill just write them.

AMP Active Codes

V0184,B1468, B1463, B146D, B14721, B147C, B1477

CCN Active Codes

U0184

FCM Active Codes

U0184
 

·
Registered
Joined
·
507 Posts
Discussion Starter · #11 ·

·
Registered
Joined
·
5,193 Posts
HERES WHAT YOU DO-PUT THE STOCK RADIO BACK IN AND THEN TAKE IT TO THEM. and see if they can explain the codes. i have 2 chargers and both HAD the boston systems in them and NOW they have been both striped and reworked with BLOWN out systems. nether one is using any of the stock wiring NOR have either one ever thrown a code. you can all so contact FUNKY CHICKEN OVER ON LX FORUMS AND SEE IF HE CAN MAKE OUT THOSE CODES [hes a dodge tech]
 

·
Registered
Joined
·
4,848 Posts
ask to see the codes its throwing first hand. a lot of these retarded service centers around here blame stuff on aftermarket equipment.
 
1 - 13 of 13 Posts
Top