Charger Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,786 Posts
Discussion Starter #1
I've been around here for a couple of months; guess it's time I made some kind of intro post. I finally got around to having my wife take some shots of the car (she has the decent camera and a photography degree). Didn't want to post anything without some pictures, and I finally have some good ones so it's high time I did this.

On my previous car (Ford Focus) I was having a problem with a broken battery clamp bolt. My own fault on that one. If you've ever seen these bolts, they're not something standard. Anyhow, I had rigged the terminal using a homemade clamp consisting of plumber's tape and a long bolt that made enough of a connection to allow the car to run, but not enough of one to charge the battery sufficiently.

One fine June morning as I'm backing out of the garage, I notice the radio cutting on and off, so I start powering it on/off to see if I can fix it. While I was doing that, the car died. Turn key, click-click-click. Wake up my wife, she jump-starts me (rawr), I say thank you, hug-kiss, and the car dies again. Okay, fair enough; dead battery didn't get enough time to charge.

Repeat the process, car dies AGAIN. Whiskey Tango Foxtrot.

Jump-start number three, and I drive to Auto Zone. Charging system test comes back fine. They charge my battery, test it again, it comes back good and within spec. I put it in the car, and while I'm buttoning everything up under the hood, IT DIES AGAIN.

AutoZoneHickEmployee comes outside again, tests the system while I rev the engine and it shows as all good. Confused, I thank him for his time since at this point the car is starting, and drive to the gas station for smokes and then to the repair shop in the same parking lot. Results: not good.

The entire charging system has corrosion, from the INSIDE of the battery cables all the way to the starter. The starter is basically seizing periodically, is what I'm told. Myself and the mechanic commiserate, I give him a cigarette ("Man, I ain't had a clove in years!"), then he gives me the news that repairs will cost roughly $2200-2500. After I changed my underwear, I ask how much life is left in the battery. He charges it again, agrees to waive the diagnostic fee, and I drive straight to the dealership (not a Dodge dealer unfortunately) and trade in the tired old roller skate on my Charger.

I have a bright silver 2007 SXT with the 3.5L (not new - use, but it's still a serious performance improvement over the Focus. :D We're not the richest couple ever, my credit is bad from past mistakes and I was $4000 upside down on the Focus, so I was just happy to get approved.

Current mods are few, but most can be seen in the below pictures.
- R/T rims
- Billet Tech emblem (possibly swapping it out for a different design, though I haven't asked BT about it yet to see if it can be done)
- Honeycomb grill insert
- Script emblem
- Rear debadged (except Ram's head - more on that in a sec)
- Rear diffuser
- Demolded
- Hood struts (package was on my desk when I got to work)

On the way or otherwise in the works:
- MoPower front spoiler (on the way)
- SRT-8 suspension (on the way soon)
- Daytona exhaust, probably w/ Brylcreem mod (in the works)

Future plans:
- SRT-8 rims
- SRT-8 rear spoiler
- DC Sports front tower brace
- Eibach sway bar package
- CAI of some sort
- JBA shorties? Dunno; we'll see

If you can't tell, I'm focusing more on the suspension and handling than I am on making it go faster in a straight line.

I mentioned the Ram's head not being removed before. The reason is that there is a defect in the metal directly behind it. I'd actually removed it before, and had to replace it. My car, as I found out when I was replacing a dead tail light bulb, has been wrecked and repaired on the sly. The Carfax report shows that it was a rental in Florida for about 4 months, reported stolen and recovered with no damage. I claim shenanigans. There was a huge rust spot behind the tail light, rust spots in the spare tire well, the trunk lid didn't line up quite right (and it has that aforementioned defect as well as paint issues) and the bumper is slightly off on one side. I can fix the bumper, I'm going to just get a new trunk lid altogether and I've removed the rust from behind the tail light, and I am starting to clean up the spots in the spare tire well this coming weekend. I'll eventually seal that area. The rest of the car has been looked over and is fine.

Anyway, I've rambled on enough. Here are the pics:




Gratuitous butt shot (ignore the scrape):


Makes me want to watch Cars:




Flash on, in the garage:


My personal favorite:


Again with the flash, and my daughter's bike in the chrome:


I only used DriWash on the paint (and the chrome) to get that shine, by the way...
 

·
Premium Member
Joined
·
5,068 Posts
nice looking ride, altho 280 posts is a bit late for an intro!!

Tom
 

·
Registered
Joined
·
1,786 Posts
Discussion Starter #3
nice looking ride, altho 280 posts is a bit late for an intro!!

Tom
Yeah, but I wanted to do an intro with pics and I was lacking in that respect before. :D
 

·
Registered
Joined
·
1,275 Posts
LOL Welcome Anyway!!!!!! :wave:
 

·
Premium Member
Joined
·
4,351 Posts
Very good looking ride you got there!
 

·
Registered
Joined
·
862 Posts
Love the script emblem. The more I look at the silver, the more I like it and I already drive a silver car.
 

·
Registered
Joined
·
1,052 Posts
Welcome from the Motor City!.
 

·
Registered
Joined
·
10,655 Posts
I wont say a little late. I didnt make my newbie post till around post 1100! LOL. Welcome to the forums, from Las Vegas!
 

·
Premium Member
Joined
·
11,946 Posts
Now that's what I call an intro post!!! :)

Welcome to the forums from Phoenix, AZ!! :wave:
 
1 - 10 of 10 Posts
Top