Charger Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
My '08 charger's Vehicle Security Alarm (VSA) Indicator light is not blinking. Does this mean something as easy as it being burned out? And doesn't that seem odd it'd burn out in less than 2yrs with it being an 08 model? I suspect the previous owner got bothered by the light & unscrewed it but honestly who would be bothered by that? So this is more likely a burnt led or a bigger problem, but what would the other reasons be?

Arming the car via fob works fine, headlights flash and all. Haven't tested the alarm but I believe its working. Is it possible that the alarm was disabled by the previous owner requesting a StarScan to disable it? Assuming that's even possible, hehe.

No EVIC on my model, btw.
 

·
Premium Member
Joined
·
3,922 Posts
My '08 charger's Vehicle Security Alarm (VSA) Indicator light is not blinking. Does this mean something as easy as it being burned out? And doesn't that seem odd it'd burn out in less than 2yrs with it being an 08 model? I suspect the previous owner got bothered by the light & unscrewed it but honestly who would be bothered by that? So this is more likely a burnt led or a bigger problem, but what would the other reasons be?

Arming the car via fob works fine, headlights flash and all. Haven't tested the alarm but I believe its working. Is it possible that the alarm was disabled by the previous owner requesting a StarScan to disable it? Assuming that's even possible, hehe.

No EVIC on my model, btw.
It's quite possible you don't have VSA on your car. As I recall, it was part of the Popular Equipment Group that included EVIC. If you don't have EVIC, I suspect you don't have VSA.

As Charlie suggests, an easy test is to roll down a window, arm/lock the car, reach in and physically unlock it then open the door. I'm guessing it's not going to do anything.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Just checked. Alarm went off, thank god! I can't imagine buying a dodge charger with no factory alarm, I would flip.

So burnt led then? Or is there no leds to change in the instrument cluster to begin with?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
I know right!

But I just turned on the car to the ON position and VSA light came on bright and held for 3-5 seconds. Then went off.

So a sleeper alarm is possible? I really hate that this light is off, it serves a purpose: My car alarm is armed, don't even think about breaking in.

Any gurus have a clue?
 
1 - 6 of 6 Posts
Top