Charger Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,184 Posts
The weak link will end up being the transmission (8HP70 vs 8HP90 for the hellcat). I'll be curious to see how it holds up. Then there's the rear diff and axles. @Punisher69 will have the laundry list of things that can go kaboom when the power gets dialed up. :)

Looks like fun!

Best,
He's already seen my list at least once lol. Those 2 tag me regularly when the word " build" shows up.
 

·
Registered
Joined
·
2,184 Posts
Thats after turbo is installed..kit came with jms fuel pump booster and id1050x injectors that as options i added.
You're going to need more fuel than that boost a pump, even at low boost levels.

This is something you do not want to skimp on. I have ebay headers and several other cut corners but the fuel system was done as overkill.

Seriously, one lean pull and that's all she wrote.
 

·
Registered
Joined
·
2,184 Posts
Was that or the race, and race required mods to bumper/grill..but atleast that can be easily changed/upgraded later on.

im suprised how well things going, considering i had do in driveway on my back and i have limited use of arms due to nerve neck damage and titanium cervical spine..but as you know, nothing can stop us from achieving more power..grunt grunt
No mods to bumper or grill with mine...
 

·
Registered
Joined
·
2,184 Posts
Bleeding is done by removing the hose on top that goes to the oil cooler...same place the bleeder screw is on the 5.7, we just have a hose there.

The SRT pages will come back in a bit.

Remote start is only lasting 10 seconds because you have a code logged. It won't work properly until the code is cleared. Probably the reason it's in limp mode.
 

·
Registered
Joined
·
2,184 Posts
Was in limp mode with the srt4 map sensor, runs fine with oem sensor.
code is p0129 which is baro out of range..aka map sensor.
yes i still need install new pcm and tune, but been told by hellion and tuner, it should run fine with stock pcm and 3psi springs…just wont run for shit with srt4 sensor..mostly wont even stay running.
so pull hose that goes to fitting in pic below? The blurry hose fitting in bottom right, next to thermostat?


View attachment 305485
Yes, that's what we bleed the 6.4 with. Top line by the tstat.

It's not liking the srt4 MAP sensor because the map values need to be changed in the tune to match the 4bangers sensor. If you go into boost with the stock one on, it'll probably run just as crappy lol.
 
1 - 8 of 8 Posts
Top