Charger Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Hello charger drivers.
Just wanted to share my experience with my transmission recently. A few weeks ago it started to make a whining noise similar to a turbo. After I drove it for about 30 minutes it would go into limp mode and would not go over 35 mph. I would have to pull over, turn off the car then start up and run normal again. I took it to auto zone for the diagnostic check and it gave 2 codes P700 P733 I think that is correct. Anyways after that I took it to a mechanic shop and paid $45 for another diagnostic check. It was the tranny. They suggested a tranny flush and fluid change and filter n gasket for $200. Or a rebuild tranny for $2,200. I said no. So I took it to mechanic I knew and they charged me $150 to change the fluid, gasket and filter. My car had 150k miles on it at the time. After it was changed the mechanic said the fluid was dirty and old and the filter was clogged up big time. I bought the car used in 2013 so I guess the tranny was never serviced. After I picked it up from the shop it ran like new. The noise stopped and hasn't went into limp mode. It has been about 2 months now. I hope this helps anybody with that problem. My car is a 06 charger SXT V6 3.5 liter. See my video below on my signature. I do work on my own car. Thanks
 

·
Registered
Joined
·
2,601 Posts
Following the recommended maintenance according to the manufacturer's service schedule does wonders for keeping a car running smooth and trouble free.
.
 
  • Like
Reactions: mando8316

·
Registered
Joined
·
1,827 Posts
Thanks for sharing, mando! Like djalbin said, keeping up with scheduled maintenance is very important. I'm happy that it sounds like you were able to make up for the previous lack of maintenance!
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
Thanks. The previous owner must have never serviced the tranny. Even after i took it several times for motor oil changes at Jiffy lube and a Dodge dealer they never said or mentioned anything about the tranny fluid when it was on their checklist and it doesnt have a tranny dipstick for me to check myself. I now do the engine oil changes myself as well as brake and rotors and whatever else i can do. please view my video on my signature. thanks.
 

·
Vendor
Joined
·
10,366 Posts
Thanks. The previous owner must have never serviced the tranny. Even after i took it several times for motor oil changes at Jiffy lube and a Dodge dealer they never said or mentioned anything about the tranny fluid when it was on their checklist and it doesnt have a tranny dipstick for me to check myself. I now do the engine oil changes myself as well as brake and rotors and whatever else i can do. please view my video on my signature. thanks.
The differential fluid is another very important neglected thing most people don't think about.





This is my SRT8 with 8k miles on it! We put a 75w125 HP Tackified Red Differential Fluid in it and smoothed it right out. Remember that everything you buy off the shelf is price driven not quality driven. Best $51.04 you ever spent for sure!

The more you learn to do your self the better as you get to see what things are doing etc.

If your going to take the time to do it, why don't you get much better materials than what you can buy off the shelf. Do your own work but do it with QuantumBlue Lubricants instead. This way you can take better care of the car, have a longer drain interval and get industrial grade materials!

http://www.chargerforums.com/forums/showthread.php?t=283226

Regards,
Brian
BND Automotive LLC:driving:
440-821-9040
www.bndautomotive.com
 

·
Registered
Joined
·
1,882 Posts
Just flushed my tranny a few months ago....shifts like butter, smooth and quick. My tranny runs abot 12* cooler on average. Prior to changing it out, the evic was a constant 177 - 180*. Now it runs a steady 163 - 167*. It also takes quite sometime to actually get to operating temp...awesome. Yes change out the diff gear oil....it makes a huge difference.
 
  • Like
Reactions: mando8316

·
Premium Member
Joined
·
1,139 Posts
My 2010 Police Charger would have come with Synthetic Trans Fluid? I need have a service done not knowing when it was last done.

Good info Mando, thanks.
 
  • Like
Reactions: mando8316

·
Registered
2006 Charger SE 3.5L
Joined
·
1 Posts
Hello charger drivers.
Just wanted to share my experience with my transmission recently. A few weeks ago it started to make a whining noise similar to a turbo. After I drove it for about 30 minutes it would go into limp mode and would not go over 35 mph. I would have to pull over, turn off the car then start up and run normal again. I took it to auto zone for the diagnostic check and it gave 2 codes P700 P733 I think that is correct. Anyways after that I took it to a mechanic shop and paid $45 for another diagnostic check. It was the tranny. They suggested a tranny flush and fluid change and filter n gasket for $200. Or a rebuild tranny for $2,200. I said no. So I took it to mechanic I knew and they charged me $150 to change the fluid, gasket and filter. My car had 150k miles on it at the time. After it was changed the mechanic said the fluid was dirty and old and the filter was clogged up big time. I bought the car used in 2013 so I guess the tranny was never serviced. After I picked it up from the shop it ran like new. The noise stopped and hasn't went into limp mode. It has been about 2 months now. I hope this helps anybody with that problem. My car is a 06 charger SXT V6 3.5 liter. See my video below on my signature. I do work on my own car. Thanks
Hello charger drivers.
Just wanted to share my experience with my transmission recently. A few weeks ago it started to make a whining noise similar to a turbo. After I drove it for about 30 minutes it would go into limp mode and would not go over 35 mph. I would have to pull over, turn off the car then start up and run normal again. I took it to auto zone for the diagnostic check and it gave 2 codes P700 P733 I think that is correct. Anyways after that I took it to a mechanic shop and paid $45 for another diagnostic check. It was the tranny. They suggested a tranny flush and fluid change and filter n gasket for $200. Or a rebuild tranny for $2,200. I said no. So I took it to mechanic I knew and they charged me $150 to change the fluid, gasket and filter. My car had 150k miles on it at the time. After it was changed the mechanic said the fluid was dirty and old and the filter was clogged up big time. I bought the car used in 2013 so I guess the tranny was never serviced. After I picked it up from the shop it ran like new. The noise stopped and hasn't went into limp mode. It has been about 2 months now. I hope this helps anybody with that problem. My car is a 06 charger SXT V6 3.5 liter. See my video below on my signature. I do work on my own car. Thanks
I hope you WIN the LOTTERY. !!
After hearing the whine and limp on my 3.5L 2006 107K mile Charger
(I've had since the cars' birth) I was sure it was beyond a DIY repair.
Your post gave me hope and I youtube'd a few how-to change/lush tranny fluid and filter vids and we are now at Transmission peace again.
a huge THANK YOU.... and let's find the idiots that said this sealed Nag1 Transmission is good for a lifetime w/no service.
 
1 - 8 of 8 Posts
Top