Charger Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Got a 2008 Charger Police Package. Transmission may be going out. Fluids burnt and high RPMs it?s got a banging sound. Gonna get it on rack and see if it?s driveshaft or transmission. I can get a SRT8 transmission out of an 07 for $400 with converter. Hell may end up putting s little stall in it while it?s out. (Nothing like my 4800 in my 1000hp 79 Malibu)
Question is are they the same transmissions? I know they?re both 5 speeds. Will I need a new TCM? The Police Package has the push button shift on the column shifter and the SRT8 has paddle shifters so I think it may work. What do y?all think?
 

·
Registered
Joined
·
5,245 Posts
The transmissions should be the same NAG1/WA580 unit. Back in the day, they had an issue where you could get water intrusion through the base of the fill tube which would cause it to really misbehave. Flushing the fluid, changing the filter, and sealing the base of the tube properly would fix it.

If you swap in the new-to-you trans, make sure you check the tube seal while it's out and deal with any issues when it's easy to do so.

Best,
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Anyone? Anyone? Seems like I can?t get too many answers here. Nobody knew about my electrical issues, now no responses on transmissions.
 

·
Registered
Joined
·
2,520 Posts
I think the reason you're not getting swamped with answers is because your situation is fairly unique, and not a lot (if any) members have experienced what you're attempting.

To start with ... electrical issues. The Police Package is different than the standard Charger. Vehicles manufactured with a police fleet equipment package are equipped with a Vehicle System Interface Module (VSIM). Then the car is outfitted with the additional lights, communication equipment, etc ... When the Charger Pursuit vehicle is auctioned or sold to the public, the VSIM and the other equipment is removed (sometimes not very carefully). This can leave the car in a "undetermined state" when it comes to the wiring harness ... and not something other Chargers owners have dealt with unless they too have a Police Pursuit vehicle. And even if they do have a Police Pursuit vehicle, each police dept. equips their vehicles differently and your Charger may have been equipped differently than theirs.

Here's a couple of PDF documents for Dodge Charger Police outfitting. They may help with the wiring harness and connections.

http://www.no1pc.org/mobile/2011_2016UpfitterGuideREV3.pdf
https://www.fcausfleet.com/assets/docs/dodge-charger_pursuit-pdf/UpfitterGuide2015v6.pdf
http://lx.bigbruin.com/2008-Chrysler-Police-Upfitter-Guide.pdf

Transmission swap considerations:
As far as I know ... the NAG1 5-speed (W5A580) is the same for all V8 Dodge Chargers. There's also the TCM (transmission control module). The TCM is located under the left side of the instrument panel. I assume the software in the TCM is the same for all V8 Dodge Chargers. You can look up the TCM part number for 2008 5.7L Hemi and SRT8 to see if they are the same.
.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Thanks for the replies concerning the transmission. Will have it on a rack Friday to determine if we have to throw other one in or if it?s driveshaft.
As far as electrical in the car, I?ve got the Upfitters Guide and pulled everything that was installed for the ?Police Package.? The problem with the 1.1 amp draw has nothing to do with any part of the Police Package. The wire to the secondary Police Fuse panel under passenger Kick panel has been removed. The amp draw was there before and after I removed everything. This has something to do with the security/fob fuse. Sorry I don?t remember number off top of my head. So far I?ve left it out and there?s no amp draw. Sons just had to use regular key. I?ve pulled every plug loose from all doors (so no actuator could be activated) and the draw was still there. Swapped out Cluster and draw is still there. Don?t know what else could be causing it unless the Can Bus is staying on for some reason. It?s nothing to do with Police Package. Also the sensors you speak of were only on the awd models in 2009 and up or so I thought. 2008 is rwd.
 
1 - 7 of 7 Posts
Top