Charger Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 · (Edited)
UPDATE!!!!!!!
It was the injector . it still works just makes alot of noise.


2016 Dodge Charger rt 5.7 hemi ticks bad until I disconnect the coil pack . Has anyone ran into this problem?

Video-https://youtu.be/lFDP2ozQ1BI

mods / 2016 Dodge Charger 5.7 hemi /cam/long tubes /6.4 intake manifold / port and Polish hesds
 

·
Registered
Joined
·
3,501 Posts
I think when you disconnect the coil the PCM will not supply fuel to that cylinder (i.e. fuel injector is not turned On/Off). Could be the fuel injector. Use a mechanics stethoscope to probe around that cylinder and see if it's the injector or something else.
.
 

·
Premium Member
Joined
·
2,800 Posts
At minimum, once the plug is removed, that cylinder is no longer firing. This would remove the pressure from the firing event from that cylinder. It may be a noisy injector, leak, or a deeper mechanical issue.

Don
 
  • Like
Reactions: White Elemant

·
Premium Member
Joined
·
2,800 Posts
Good God man! I LOVE the lope on that cam! Question is, is it all lope, and no go, or????????
This is how the 5.7L should sound, as it rolls off of the assembly line.

Don
 
  • Like
Reactions: White Elemant

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
I think when you disconnect the coil the PCM will not supply fuel to that cylinder (i.e. fuel injector is not turned On/Off). Could be the fuel injector. Use a mechanics stethoscope to probe around that cylinder and see if it's the injector or something else.
.
You are one great Genius ,Thanks for the help. You were correct
 

·
Registered
Joined
·
3,501 Posts
Glad it's fixed.
.
 
1 - 11 of 11 Posts
Top