Charger Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I'm new to the Forums, and this is my first post, so forgive me if this is an oldie!

My electronic throttle control has a miserable lag or dead spot just off idle. When trying to accelerate gently (as in tight parallel parking situation) there is initially no response, then too much. At standstill, in either Park or Drive, I can depress the pedal 1/2" with no response on the tach.

The dealer has applied Flash Update 08190690 without noticeable effect. I've also performed two varieties of throttle pedal calibration procedures with no effect.

Other 5.7 cars I've driven show the same symptom to varying degrees, so it appears to be a common problem.

Any advice, or previous threads I should look for?

NCLimey
 

·
Registered
Joined
·
13,222 Posts
Try this; no promises:

Turn ignition on, but don't start.

Wait until the car checks itself and nothing more is happening.

S-L-O-W-L-Y depress the accelerator until it is floored and HOLD IT THERE. This should take about 15 secs, and hold for a few more.

S-L-O-W-L-Y release the accelerator, taking another 15 secs.

Turn car off.


Restart and test for improvement.

Remember: NO PROMISES! :nervous s
 

·
Registered
Joined
·
360 Posts
Are you talking about the lag when you go from reverse to drive or just straight from park to drive?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7 (Edited)
Hi, Charger Marc. I don't understand your question. Could you elaborate, please!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
Are you talking about the lag when you go from reverse to drive or just straight from park to drive?
My lag has nothing to do with the transmission. It's purely a matter of engine response to the accelerator pedal!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
Thanks, Crow. I'll go see my dealer!
 

·
Registered
Joined
·
10,665 Posts
ETC is calibration does not require a star scan tool. I've done. Numerous members have done it. Your EVIC tells you you've done it if you've done it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Thanks, TBYDaytona40: I've PMed you for more info on how to do ETC cal. on EVIC.
 

·
Registered
Joined
·
2,069 Posts
ETC is calibration does not require a star scan tool. I've done. Numerous members have done it. Your EVIC tells you you've done it if you've done it.
Yes it does. This whole ETC recal' is a forum myth. There is no offical written documentation anywhere on how to do this, other than with a Starscan.

Please tell me exactly what the EVIC states in terms of re-calibration completed. I do know EVIC shows pedal position, buts that's as far as that goes.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #15
Thanks, Crow. My dealer's Service Manager is happy to try the 21-020-06 TSB for me. This is the SRT8 1-2 shift quality fix that apparently will work on 5.7s and helps the throttle response problem.
Are you aware of any other TSB or starscan tool procedure for calibrating the ETC?
Also, I can find no info in the EVIC regarding recalibration status. It just says Pedal position zero until I depress the pedal as much as 1/2 inch!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #16
Hi, Dawnscharger: What's with the Union Jack? As you might tell from my username, I'm from over there too!
 

·
Premium Member
Joined
·
20,935 Posts
Crikey - not another Brit! :D
 

·
Registered
Joined
·
13,222 Posts

·
Premium Member
Joined
·
20,935 Posts
Hehehe - just few at a time....you'll never notice.... :D
 
1 - 20 of 26 Posts
Top