Charger Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2012 Dodge Charger RT
Coolant fan was smoking, car got hot and notice the fan wasn’t working properly. Changed fan, flushed, changed t-stat and sensor. Ran good about a day check engine light comes on. Now low coolant code Po128. Temperature stays barely above the C. We have since, changed t-stat 3 times, sensor 3 times. Runs ok not as hot as it use to register but engine light come right back on. Runs to cool. We don’t know what else to do. Any suggestions?
 

·
Registered
Joined
·
776 Posts
What you need to determine is whether this is a mechanical (thermostat) or electronic (sensor/wiring/ECM) problem.

First thing to check is the actual part number of the thermostat(s) you put in. Then verify that they don't start to open until 200° or so. Use a pot of hot water on the stove and a cheap temperature gun from that big website named after a river in South America.

Once the car is warmed up... say, five to ten minutes...use the temperature gun on the upper radiator hose to see if coolant is flowing. You could try squeezing it as well, but be careful to avoid burns.

Then check to see if it delivers heater output roughly as quickly and at the same temperature as it used to.

You should also pick up a cheap ELM327 Bluetooth adapter, grab any available Android device, and download the free demo version of AlfaOBD to scan for extended ODBII codes.

Then come back and post the results.
 

·
Registered
Joined
·
2,072 Posts
P0128-THERMOSTAT RATIONALITY
Set Condition:
The PCM predicts a coolant temperature value that it will compare to the actual coolant temperature. A significant difference results in a diagnostic code (P0128) being logged. It's because the PCM sees the actual engine coolant temperature is too far below the predicted engine coolant temperature.
It could be due to low coolant level, thermostat staying open, one of the temp sensors, or wiring harness/connector.
You replaced the thermostat and fan. Check the wiring harness/connectors to the ECT (engine coolant temp) sensor and make sure it's good. What's the ambient temp reading on the instrument panel? Is it within 5°F of the actual outside ambient temp? If it's significantly different than the actual outside temp the AAT (ambient air temp) sensor is bad. If the AAT is good, and wiring harness/connector to the ECT is good, the problem may be the ECT sensor is bad.
.
 
1 - 5 of 5 Posts
Top