Charger Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I've had gremlins somewhere in the car since I got my 2010 Charger SXT. I've replaced the ECM, PCM, throttlebody, and the actuator. Recently made a friend that is a retired chop mechanic, and he said if I replaced the actuator and was still having an issue the problem is the intake plenum. After replacing the actuator I pulled the positive terminal on the battery for about 12 hours, and the check engine, traction control, and red lightening bolt came on a few times, but the last two times I've driven short distances only the check engine light comes on. I am hoping that the issue is resolved, and it's just taking time for everything to reset completely. Is there a way to service the runner valve inside the intake plenum, and if not does anyone know where I can find an aftermarket intake plenum that doesn't cost an arm and a leg?
 

·
Registered
Joined
·
28 Posts
Since you stated the you have a CEL after replacing the actuator, have you checked to see if there are any codes stored and looked to see what the codes are for?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Before replacing the actuator, 5 different codes came up including one stored in the trans (don't remember what they were). After replacing the actuator and disconnecting the battery overnight only one code came up pointing at the actuator, and it was a cheap ($60) one I ordered from Amazon so I went to Car Quest and got a name brand ($200) replacement. I have yet to go and pull the codes again, but I'm still having the same issues.
 
1 - 3 of 3 Posts
Top