Charger Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
It's been awhile since I've actually logged onto this site, even though I Check it out regularly as a spectator. I was kinda taken off guard back when I posted my times at Lapeer Dragway (best of [email protected] on the bottle) and 12.88 on motor with just 17inch steel wheels with drag radials, Air Raid CAI, 180 Degree thermostat, and .25 cent fan mod. Some of you guys really tore me a new one. Truth is, I was ignorant about nitrous and ran a dry shot on my car when it should have been wet.

I've since corrected that issue and now have a 100 wet shot. Also installed the predator performance 93 tune. Went to Lapeer for last runs of the year and on first all motor run ran [email protected] with a 1.86 60ft time. Second pass on motor was [email protected] with a 1.95 60ft time. Third pass on motor was [email protected] with a 1.87 60ft time. On the bottle, 1st pass was [email protected] with a remarkable 1.75 60ft time. Second pass almost identical. Raced an 07' black vette on motor and thrashed all over him. He pulled me hard as you know what at the top end because I rushed back out to race him without using the predator to load the performance 93 tune. was retarded 2 degrees and lost all top end. But he still lost. Also watched a red 07' GT500 run an [email protected] before smoking his clutch. I followed with my [email protected] and he came over scratching his head wondering how I ran faster. I showed him my setup and he still just could not understand. He came over about four times and just walked around my car, whispering to his friend. He had 10k tied up in his car but could not get it to hook up. On the 11.99 run he had to launch in 2nd just to keep from smoking the tires.That car is a beast.

I had a really good time. My car always get lots of attention when at the track. Anyways, thanks to the guys that provided good advice and helped prevent me from killing my motor. I did however, take everything off and put it back to stock after I realized I had screwed up. I took it to the dealer and said that it was missing so they'd put it on the computer to check for any damage. Amazingly, she came back with a clean bill of health. I know I scewed up so I don't need any cosigners,but it's amazing that my motor held up under such insane conditions. Either god was watching over my [email protected]$$ or these blocks can really handle some very extreme conditions. Oh yeah, I just had to say that the half shafts are fine also after more than 50 passes this summer. Someone must be watching over me....
 

·
Registered
Joined
·
1,655 Posts
Wondered where you went and yes they did hammer you at first, seemed
to work itself out though in the end...
 

·
Registered
Joined
·
2,568 Posts
It's been awhile since I've actually logged onto this site, even though I Check it out regularly as a spectator. I was kinda taken off guard back when I posted my times at Lapeer Dragway (best of [email protected] on the bottle) and 12.88 on motor with just 17inch steel wheels with drag radials, Air Raid CAI, 180 Degree thermostat, and .25 cent fan mod. Some of you guys really tore me a new one. Truth is, I was ignorant about nitrous and ran a dry shot on my car when it should have been wet.

I've since corrected that issue and now have a 100 wet shot. Also installed the predator performance 93 tune. Went to Lapeer for last runs of the year and on first all motor run ran [email protected] with a 1.86 60ft time. Second pass on motor was [email protected] with a 1.95 60ft time. Third pass on motor was [email protected] with a 1.87 60ft time. On the bottle, 1st pass was [email protected] with a remarkable 1.75 60ft time. Second pass almost identical. Raced an 07' black vette on motor and thrashed all over him. He pulled me hard as you know what at the top end because I rushed back out to race him without using the predator to load the performance 93 tune. was retarded 2 degrees and lost all top end. But he still lost. Also watched a red 07' GT500 run an [email protected] before smoking his clutch. I followed with my [email protected] and he came over scratching his head wondering how I ran faster. I showed him my setup and he still just could not understand. He came over about four times and just walked around my car, whispering to his friend. He had 10k tied up in his car but could not get it to hook up. On the 11.99 run he had to launch in 2nd just to keep from smoking the tires.That car is a beast.

I had a really good time. My car always get lots of attention when at the track. Anyways, thanks to the guys that provided good advice and helped prevent me from killing my motor. I did however, take everything off and put it back to stock after I realized I had screwed up. I took it to the dealer and said that it was missing so they'd put it on the computer to check for any damage. Amazingly, she came back with a clean bill of health. I know I scewed up so I don't need any cosigners,but it's amazing that my motor held up under such insane conditions. Either god was watching over my [email protected]$$ or these blocks can really handle some very extreme conditions. Oh yeah, I just had to say that the half shafts are fine also after more than 50 passes this summer. Someone must be watching over me....
Welcome back, man. Great times, especially the 60's. Any more plans (heads, cam?) or are you waiting for warranty to expire and better programming to be available?
 

·
Registered
Joined
·
10,665 Posts
Glad to hear your runs! Great job. Oh, and since you have bee, and I covet.... I hate you.
But not really


but really

but not really...
 
1 - 5 of 5 Posts
Top