Charger Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello,

I'm having strange complaints with my 2018 Charger which I recently purchased (pre owned). It's an SXT model with U connect 7.1.

- When the headlights are on, putting the car in reverse, the camera makes the screen go to full brightness. It's unbearably bright at night and the dimmer switch works in reverse. ie if I increase the instrument panel brightness the main screen brightness reduces to 50%. The only way to quickly resolve this is if I press the switch off screen button, then the main screen becomes around 50% brightness and the dimmer switch works properly ie Reduces brightness of instrument cluster along with main screen.

- When on a call or radio, when the reversing sensors switch on, they completely mute the call/music instead of just lowering the volume. So I can hear the caller or the music in between the beeps of the proximity sensor

-AC circulation randomly switches off for 10-15 seconds, without any error and without circulation light switching off. I realise this as I start getting smells from outside like Diesel fumes on the highway etc. My friend with a Grand Cherokee 2015 experiences the same. This happens for a few seconds and then it stops.


Wondering if anyone has faced these and how they can be resolved?

Also, is there some way to play video files when the car is in park? The audio on mp4 files works but no way to see the video.


Thanks in advance.
 

·
Registered
2013 Charger R/T AWD
Joined
·
25 Posts
Best thing I could tell you to do is stop in and talk to your dealer and ask if there are any updates for the hvac and radio modules. Also if there are any other flash updates. Being a mopar tech we see weird stuff like that all the time and most times a flash can fix it. Not saying that there will be a flash but it's a great place to start. Hope that helps.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Best thing I could tell you to do is stop in and talk to your dealer and ask if there are any updates for the hvac and radio modules. Also if there are any other flash updates. Being a mopar tech we see weird stuff like that all the time and most times a flash can fix it. Not saying that there will be a flash but it's a great place to start. Hope that helps.
Thanks a lot for the reply. I will schedule an appointment with them. Issue is that some of these concerns are hard to explain.

Like the HVAC issue is not a constant one and is hard to show, happens randomly. Even the reverse camera display, sometimes doesn't respond to the switch off button. Unless I'm showing to an electrical guy and not the service advisor they will not get it.

One question though, these are genuine issues right and not by design? Because HVAC issue is common on the Jeep (something to do with the humidity sensor) . The reverse beep issue I'm unsure. Display brightness is surely an issue.

Will visit this week and keep you posted. Thanks once again.
 

·
Registered
2013 Charger R/T AWD
Joined
·
25 Posts
The "mute" function while in reverse is I believe a normal condition. Usually from what I understand from a tech note is that it takes priority since it's a safety feature. The humidity sensor is a common issue at least in my area due to our wild temperature swings throughout the year so it's entirely possible. One test to see if it's that sensor turn on your AC - dash output air and hit the recirculation button. Off it blinks a few times and goes out it's more than likely a cause for that sensor. As far as hvac issues with fan speeds, lag, or a no run condition that module in most cases has a flash available. Also the touchscreen radios and the hvac are tied together passively so one may cause the other. Also one thing to make sure of is ask how much time it states for each flash update. In most cases it's .2 or .3 hours payout. Also ask what the lop# is and I can make sure. Or they may do it 1 hour diag including flash updates. Anyway maybe I'm going down to much of a rabbit trail. Hope that helps.
 

·
Registered
Joined
·
2,792 Posts
Welcome to the forums from Texas.

The mute function in reverse is common if you have backup warning sensors. It allows you to hear the warning tone. As far as other issues, it appears the Multi Function Radio is bad.

When these issues appear, take cell phone video and show it to the service department so they can see the problems because sometimes the problems do not replicate when being diagnosed.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
The "mute" function while in reverse is I believe a normal condition. Usually from what I understand from a tech note is that it takes priority since it's a safety feature. The humidity sensor is a common issue at least in my area due to our wild temperature swings throughout the year so it's entirely possible. One test to see if it's that sensor turn on your AC - dash output air and hit the recirculation button. Off it blinks a few times and goes out it's more than likely a cause for that sensor. As far as hvac issues with fan speeds, lag, or a no run condition that module in most cases has a flash available. Also the touchscreen radios and the hvac are tied together passively so one may cause the other. Also one thing to make sure of is ask how much time it states for each flash update. In most cases it's .2 or .3 hours payout. Also ask what the lop# is and I can make sure. Or they may do it 1 hour diag including flash updates. Anyway maybe I'm going down to much of a rabbit trail. Hope that helps.
Thanks a ton for a thorough reply. I don't have recirculation light blinking and turning off issue, so I guess the sensor is OK.

Regarding the rest, I guess I will read out your message to the dealer directly :D
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Welcome to the forums from Texas.

The mute function in reverse is common if you have backup warning sensors. It allows you to hear the warning tone. As far as other issues, it appears the Multi Function Radio is bad.

When these issues appear, take cell phone video and show it to the service department so they can see the problems because sometimes the problems do not replicate when being diagnosed.
Thanks for the idea. I will record a video of the display lighting and share with them.

Hvac bit, I can't do much but to bear with the frequent fumes stench I guess.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Hello,

I gave my car to the dealer service center, they did an HVAC System update which fixes issues with circulation flaps that open randomly. They also did a display update but that didn't resolve the brightness issue. They say it may be a standard feature. Summary of the issue is as follows once again:


Car lights off
Instrument panel full brightness
Center display brightness as set by me (manual mode)

Car lights on
Intrument panel at reduced brightness
Center display reduced brightness as set by me (manual mode)


In reverse gear, car lights off
Instrument panel full brightness
Center display brightness as set by me (manual mode)


In reverse gear, car lights on (this is where the issue is)
Instrument panel as set by me
Center display brightness goes to Full brightness (manual mode)
If I make the make the Intrument panel brighter via the dimmer then the display brightness.

Is this normal? It's unbearably bright :(
 

·
Registered
2013 Charger R/T AWD
Joined
·
25 Posts
Ah yes. The feature is to give you the most amount of visibility in the camera. That part is normal.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Hello,

I gave my car to the dealer service center, they did an HVAC System update which fixes issues with circulation flaps that open randomly. They also did a display update but that didn't resolve the brightness issue. They say it may be a standard feature. Summary of the issue is as follows once again:


Car lights off
Instrument panel full brightness
Center display brightness as set by me (manual mode)

Car lights on
Intrument panel at reduced brightness
Center display reduced brightness as set by me (manual mode)


In reverse gear, car lights off
Instrument panel full brightness
Center display brightness as set by me (manual mode)


In reverse gear, car lights on (this is where the issue is)
Instrument panel as set by me
Center display brightness goes to Full brightness (manual mode)
If I make the make the Intrument panel brighter via the dimmer then the display brightness.

Is this normal? It's unbearably bright :(
Pics attached.. If they make sense.
 

Attachments

·
Registered
Joined
·
10 Posts
Discussion Starter #12
Ah yes. The feature is to give you the most amount of visibility in the camera. That part is normal.
But why brighter at night? :(
Some more pics here, in this case, instrument dimmer is at highest setting (before cabin lights switch on) and a lower setting, see the center display brightness respond the opposite way.
 

Attachments

·
Registered
Joined
·
10 Posts
Discussion Starter #13


You can't adjust it using those dials to the left of your steering?
That's nuts!
Hehe, nice gif exactly how I feel. Here I have a nicely tinted, private cozy car and then suddenly I get these stage spot lights on me..

I just attached the pics with the dimmer settings to Hemitec, please have a look.
 

·
Registered
2013 Charger R/T AWD
Joined
·
25 Posts
Looks normal. One thing to check in the display settings is put it in auto to see if it still does it.
 

·
Registered
Joined
·
860 Posts
It's annoying at best. I haven't seen a solution to the issue though. Mine is the same way and once it's dark outside and my eyes are adjusted to it, that stupid screen will blind me trying to back up.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
It's annoying at best. I haven't seen a solution to the issue though. Mine is the same way and once it's dark outside and my eyes are adjusted to it, that stupid screen will blind me trying to back up.
That's so disappointing to hear! I was hoping it's a solvable glitch.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
It's annoying at best. I haven't seen a solution to the issue though. Mine is the same way and once it's dark outside and my eyes are adjusted to it, that stupid screen will blind me trying to back up.

Hello,

Attached are pics with display mode set to auto.

Regards,
A
 

Attachments

1 - 18 of 18 Posts
Top