Charger Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I am having reception problems while driving around, the satellite radio signal cuts in and out with no obstructions overhead. The normal stations do not do this. Has anyone else had this problem.
 

·
Super Moderator
Joined
·
11,623 Posts
I am having reception problems while driving around, the satellite radio signal cuts in and out with no obstructions overhead. The normal stations do not do this. Has anyone else had this problem.
I do on occasion find I lose the signal for no apparent reason.

I also find the SLIGHTEST obstruction causes me to lose the Sirius signal. Most days I cannot get a signal in my own driveway (house blocking it).

I never had this issue with my Impala and the XM signal...

Everyone mocks the new antenna on the '08 Charger, but it is probably necessary...

-=FLEX=-
 

·
Registered
Joined
·
1,366 Posts
Mine went totally out,they had to replace the antenna. I'd take it to the dealer.

Good luck,
Rex
 

·
Registered
Joined
·
358 Posts
No problems that I've noticed with mine - signal usually great. But, I tend to play my mp3 most of the time.
 

·
Registered
Joined
·
6,299 Posts
Mine is awful too. It'll be fine for weeks, then suddenly it cuts out for 30 seconds, or 5 secs, or 10 mins....very unrelaible.

About 6 months I had it in the dealership and mentioned it...svc mgr said they tightened 3 connections...he was calling the mothership to see what else they could do. After I left the dealership, on the way home....I got NO SIGNAL.

Love the convenience of Sirius or else I'd have canceled it with the antenna issues.
 

·
Registered
Joined
·
838 Posts
There are 2 types of signal loss. Random loss and consistant loss.
Depends which you have and what can be done.

Random loss: signal goes to no signal when there are no obstructions and no heavy foliage (very large trees). This cannot be repeated by driving though the same area again and it does not drop signal. This is an issue and all connections and antenna sould be checked.

Consistant loss: is when the signal drops out but there are no obstructions but it happens in the same location day after day. I suspect this is an interfernce issue and nothing can be done to fix on your car.
 

·
Registered
Joined
·
6,299 Posts
yeah, mines a random loss issue...
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #8 ·
There are 2 types of signal loss. Random loss and consistant loss.
Depends which you have and what can be done.

Random loss: signal goes to no signal when there are no obstructions and no heavy foliage (very large trees). This cannot be repeated by driving though the same area again and it does not drop signal. This is an issue and all connections and antenna sould be checked.

Consistant loss: is when the signal drops out but there are no obstructions but it happens in the same location day after day. I suspect this is an interfernce issue and nothing can be done to fix on your car.


It appears that I am having ramdom loss because it sometimes happens for 2 sec maybe 5 sec etc. but always returns. I like the satellite radio capabilities but I will not pay for it in a year if this can't be fixed, are there any type of signal boosters that I can get installed in the car. I don't want to install a longer antenna because I already don't like the one that is already installed. I was hopeing to be able to install a shorty antenna but I see that that will not get the reception needed. Thanks for all the responses at least I know it's not only this car. I will take it in to let them look at it anyway.
 

·
Registered
Joined
·
359 Posts
yeah i get a 1 sec loss occasionally. and if i pull under any structure (like the car wash) i will lose it.

so this raises the question: how are the personal sattelite recievers any good? I want to purchase one to listen to at my desk at work. (and my desk is not outside!!)
 

·
Registered
Joined
·
1,540 Posts
Folks, it's NOT the antenna - it's the signal. I have had the Sportster in my Ram for two years now, with the antenna on the roof, and it is even worse than the Charger's reception. Cloudy days, or lots of tree cover (which we have here in Chester County), and the signal goes away.

There is a lot of talk about this over on the Sirus forums, and the signal losses are mainly the lack of ground repeaters.

Again - 99% of the time, it's not your electronics - it's Sirius.
 

·
Super Moderator
Joined
·
11,623 Posts
Again - 99% of the time, it's not your electronics - it's Sirius.
That was my suspicion, and good to know...I guess...:knockout: :knockout: :knockout:

I wonder if it will get better once XM and Sirius complete the merger?

-=FLEX=-
 

·
Registered
Joined
·
1,540 Posts
I hope. If you live in an area with ground repeaters, you're good to go. If not, it's it-or-miss. Some days her in Chester County, it's virtually un-listenable. But, can't give up Stern, so I deal with it.:lol:
 

·
Registered
Joined
·
25 Posts
I have Sirius and xm in all of my vehicles. No problems. My sirius in my charger flatlined 4 or 5 months ago! No signal. It's not a connection problem either. What now? Ive heard the antennas have gone bad. Ive also heard its a tuner problem.I think we will find out what the dealer says tommorrow.
 

·
Registered
Joined
·
13,222 Posts
My Sirius signal almost never drops unless I'm under heavy tree cover, in a parking garage, or under an overpass/tunnel.
 

·
Registered
Joined
·
2,948 Posts
I am having reception problems while driving around, the satellite radio signal cuts in and out with no obstructions overhead. The normal stations do not do this. Has anyone else had this problem.
some spots may have a dead spot area. its like that on 83 southbound right north of towson, right before you get to the padonia road exit.

reg radio flashes out for a bit as well...
 

·
Registered
Joined
·
363 Posts
I notice I get the random loss signal on cloudy days. Also I have a spot on th way to work that I always loose reception with no obstructions, like some one said some kind of interference
 

·
Registered
Joined
·
1,139 Posts
My Sirius has been working fine since I got the car last month.

Friday afternoon I removed the battery cables to install some anti-corrosive rings around the terminals. The next morning I had to sync the BAS and ESP by turning the wheel each way. Sirius worked fine and so did everything else.
That Saturday night I was leaving work and Sirius would only play and display channels 66 - 193. If I roll past 193 it goes back to 66 or 100.
Anything past 66 or 100 is a blank screen with no audio.
Occasionally when I first turn on the radio, Sirius is on channel 1, playing music like it should but if I try to move up it jumps to 184 and continues the loop explained above.

I'll check the manual but is there something that requires my attention after reconnecting the battery?

I have the 6 speaker system w/ single CD.

Thanks,
GB
 

·
Registered
Joined
·
349 Posts
My Sirius works perfectly. It even works in my garage at home. I have four other subscription (my home, wifes car, Stiletto and my office) and I never have any issue with reception. The only "drops" are the natural one due to going under overpasses, but they last about 1 second. It may have something to do with the region like someone mentioned. I live in the Dallas Ft Worth metroplex - dunno :confused:
 

·
Registered
Joined
·
103 Posts
I had XM on an ATV and it worked in the woods (most of the time). I couldn't imagine something like this not working on normal streets.
 

·
Registered
Joined
·
448 Posts
That was my suspicion, and good to know...I guess...:knockout: :knockout: :knockout:

I wonder if it will get better once XM and Sirius complete the merger?

-=FLEX=-
:lol: I would not hold my breath.
 
1 - 20 of 24 Posts
Top