Charger Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Hey, does anyone know where i can get real xenon lights for a SXT Charger. And no i do not want the $20 bulbs, i looking for the real thing. Any help will be thanked for.
 

·
Registered
Joined
·
96 Posts
Chargedup said:
Hey, does anyone know where i can get real xenon lights for a SXT Charger. And no i do not want the $20 bulbs, i looking for the real thing. Any help will be thanked for.
Suggest you try fitting the system from the 300c. I haven't measured them, but you might be able to fit the HID in place of the projector beam.
 

·
Registered
Joined
·
69 Posts
Chargedup said:
Hey, does anyone know where i can get real xenon lights for a SXT Charger. And no i do not want the $20 bulbs, i looking for the real thing. Any help will be thanked for.
got a set of McCulloch 6000K installed.
296 shipped for the 6000K kit













 

·
Registered
Joined
·
143 Posts
scirocco16valve said:
got a set of McCulloch 6000K installed.
296 shipped for the 6000K kit













How long have you had these? And do you have any flickering. On another thread someone reported that Tbyrne had said that some of these aftermarket kit will cause flickering. on our cars.
 

·
Registered
Joined
·
69 Posts
Fedexjetmx said:
How long have you had these? And do you have any flickering. On another thread someone reported that Tbyrne had said that some of these aftermarket kit will cause flickering. on our cars.

3 months and no flickering at all.
come with a 1 year warranty.
:grin:
 

·
Registered
Joined
·
1,037 Posts
I believe the reason for the flickering was that the system was turning on the DRLs (for those people who have daytime running lights or decided to have the dealer activate the option in the car's computer system). The computer system supplies a lower voltage for DRLs. I think it was ~8v. The ballasts probably do not like the lower voltage, hence the flickering.

If you install true HIDS, just have the dealer deactivate the DRLs in the computer system.

Just my 2 cents.
 

·
Registered
Joined
·
69 Posts
Charger06RT said:
I believe the reason for the flickering was that the system was turning on the DRLs (for those people who have daytime running lights or decided to have the dealer activate the option in the car's computer system). The computer system supplies a lower voltage for DRLs. I think it was ~8v. The ballasts probably do not like the lower voltage, hence the flickering.

If you install true HIDS, just have the dealer deactivate the DRLs in the computer system.

Just my 2 cents.

it is not the voltage but the amperage. HID draw like about 20 amps at startup and once started they draw about 5 amps. Halogens on the other hand draw 15 amps give or take an amp or so once lit.
 
1 - 8 of 8 Posts
Top