Charger Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
So, I recieved my Xenonpimp 8k HID lights today. They were packaged well and I love the color. However, once I hooked them up on my 2006 dodge Charger, they were doing the infamous "flickering." The left headlight (Drivers side) seems to be doing it a whole lot more than the right side. Additionally, the relay is making a whole lot of noise (clicking). I can even hear it when the hood is shut and the engine is running. Any ideas what is going on? Think it could be a bad relay? Thanks guys!
 

·
Registered
Joined
·
6,124 Posts
Almost all the HID kits have a flickering problem until extra stuff is added. Only one brand I know that specifically guarentees no flicker for the charger, does xenonpimp claim their kit doesnt flicker?
 

·
Registered
Joined
·
263 Posts
According to this, yes:
http://www.xenonpimp.com/page010.html

Q: Will it work on my Dodge charger or other newer Daimler Chrysler vehicle. Because I hear that you have flickering issues when you install them on newer Daimler Chrysler vehicles.

A: Yes. My kits will work with your newer Daimler Chrysler vehicle MOST other kits wont work right and you will get flickering with other kits. Some places charge you extra money for a solution to this problem, I supply the plug and play solution free with the purchase of a kit. Just ask the guys at the chargerforums.com
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #4 ·
Yeah. Thanks Quicksilver. I had read that and searched the forums and many of the members reccomended Xenonpimps, so I went for it.....
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #6 ·
I emailed them. So I guess we will find out how their customer service is?!? I'll keep ya posted on any developments. Thanks-
 

·
Registered
Joined
·
12,630 Posts
My kit/s work perfectly from xenonpimp, as does my buddies on his 300
 

·
Registered
Joined
·
1,893 Posts
from what i remember when i did my own harness the capacitor was connected to two pins on the relay. it was not used to connect/link the stock wiring to the relay.
 

·
Registered
Joined
·
458 Posts
I have to xenon pimp kits in both my and my wifes charger. No flicker in either kit. Make sure they are grounded and if you still get a flicker just send'm back.
 

·
Registered
Joined
·
150 Posts
Is it plug and play or you need to splice wires? Well my problem with my hid's are that when I disarm the car the lights would come on but then I would start the car and then try to turn them on they wont turn on. What I would have to do everyday to get them to stay on was disarm the car and turn the headlight switch on before I started the car so they would stay on.
 

·
Registered
Joined
·
6,299 Posts
Is it plug and play or you need to splice wires? Well my problem with my hid's are that when I disarm the car the lights would come on but then I would start the car and then try to turn them on they wont turn on. What I would have to do everyday to get them to stay on was disarm the car and turn the headlight switch on before I started the car so they would stay on.
Wow, thats way too much work, I couldnt stand to keep doing that..
 

·
Registered
Joined
·
551 Posts
Cdoogles i have had both a regular HID kit and xenonpimps on my car. My first kit did as you said flicker then made a very loud noise from the relay, this kit was from some website i dont remember. I sent them back and bought xenonpimps and they worked without flaw. They were absolutely perfect. If you go to contact you can contact them via aol instant messanger that is the fastest and easiest way to contact them. I have spoke to them a few times and they are great with customer service, im sure they will help you if you contact them.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top