Charger Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
608 Posts
Discussion Starter · #1 ·
So last night I was cruising along interstate 71 when suddenly it turned into a parking lot. After 15 minutes I decided to cross the median and start moving again. Get going and then take backroads for the next 50 miles or so. I make my way back to the expressway without really hitting any red lights or having to slow down too awful much and I'm thinking all is good.

Then I get on the offramp and get below 15 miles per hour and hear this horrible scraping noise coming from right below the car!! :confused:
Interestingly enough it goes away as soon as I get the car back above 15mph, and comes back every time I go below 15...

So by this time I have a pretty good idea of what the problem is but no idea about what caused it. Ended up jacking the car up and throwing it in the trunk. :icon_mad:

So, since I've only got one bolt left for this oil filter cover, I'm probably just going to leave it off. I think I read somewhere about a mod that allowed you to remove it without any negative consequences. If anybody remembers the details or has a link to it, that would be great.

Also, if anyone has any idea why this fell off, that would be nice to know too...

Rant off
:soapbox:
 

·
Premium Member
Joined
·
11,698 Posts
either wasn't installed properly, or it got caught on something

It's principally there for aerodynamics, but also may have some cooling impact. Many people have left it off without issues.
 

·
Registered
Joined
·
439 Posts
Dude....You crossed the median....Would this have been a curbed median? and if so WTF????????????
 

·
Registered
Joined
·
608 Posts
Discussion Starter · #4 ·
either wasn't installed properly, or it got caught on something

It's principally there for aerodynamics, but also may have some cooling impact. Many people have left it off without issues.
I was wondering if I just didn't tighten the bolts enough the last time I changed my oil but that was more than 5000 miles ago. Either way, still a pain... Thanks for the info about leaving it off, I really appreciate it.

Dude....You crossed the median....Would this have been a curbed median? and if so WTF????????????
Not sure I understand the big deal. It was on a divided highway when traffic was stopped and I couldn't afford to sit on a closed road all night. Not a curbed median, just alot of grass. Didn't bottom out either.


I'll probably just leave it off but it really is kinda disappointing that I can't even pinpoint exactly why it came off.
 

·
Premium Member
Joined
·
5,531 Posts
You might not have bottomed out, or you might have and not have noticed. It could have hit enough to knock it off.
 

·
Registered
Joined
·
113 Posts
I agree with the last 2 posts
 

·
Registered
Joined
·
1,037 Posts
It must have gotten hooked on something and ripped off.

Just be careful driving through puddles to avoid water entering the engine bay and intake (i.e. hydro-lock)
 

·
Registered
Joined
·
608 Posts
Discussion Starter · #8 ·
It must have gotten hooked on something and ripped off.

Just be careful driving through puddles to avoid water entering the engine bay and intake (i.e. hydro-lock)
I appreciate the warning, I'll keep an eye out


Sorry if I came off sounding rude or ignorant in any way, I was not having the greatest day ever when this happened.

Thanks for all the input, and I suppose it is possible I snagged it on something without noticing, I'll have to look under the car for clues the next time I get a chance. Until then it'll just have to be a mystery!
 

·
Registered
Joined
·
716 Posts
Did you check all the rest of the bolt holes to see if the bolts were still in them?

I see that you mentioned about having one bolt left, but was that the one that was still attaching it? If there are bolts in the holes then that might give you some insight as to how it came off:

Bolts in hole or holes = torn or ripped off
No Bolts in holes = Bolts not tight, fell off
 
1 - 9 of 9 Posts
Top