Charger Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone

I got a 2012 superbee 80000kms since i live in canada, last year, before winter came out, I got a check engine light with the p2096 code that went away by himself. Last month, when I decided to get my car back on the road for the upcoming summer season, the code resurfaced. , So I decided to bring the car to the dodge dealer where i've purchased the car 3 years ago, they replaced the 2 o2 sensors on bank 1 and erased the code. 2 days later, the check engine came back, again , i went to the dealer for a second time, they spent 1000$ of labor time just to let me know that they found nothing, no leak nothing erased the code and send me home. Third time, my check engine came back on, got angry, call the sales manager at my dodge dealershop and tell me that they will change my pcm and reprogrammed it. Guess what, the car is making sort of a rattle noise coming from the engine, when i accelerate , which i think is engine pinging. Can someone please help me
Sorry for my ebglish, i'm a french canadian guy:(
 

·
Registered
Joined
·
84 Posts
Hey sorry to hear that. I am unimpressed with Dodges ability to diagnose and fix their own cars. Not the same code as you are having, mine is a P0441. I have been to the dealership 13 times since buying it new. They have run every test multiple times replaced basically the entire system, reprogrammed twice and they always tell me they don't know how to fix my car. They can find the problem but dodge and chrysler both cannot fix it for some reason. Good luck I hope you have better luck than me!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Look like we have the same problem with dodge unable to fix their own cars,I've just contacted the main chrysler customer care service and waitingfor their senior customer care advisvor To call me back. Is your problem been fixed ?
 

·
Registered
Joined
·
84 Posts
Nope one opened 2 cases with Chrysler and the dealership has opened 2 as well. They have tried everything they told them to and they even said no idea lol
 

·
Registered
Joined
·
11 Posts
I have a 2008 Dodge Charger se 2.7 v6... a year ago I received engine lights for the catalytic converter‘s on both sides. I replaced both of the catalytic converters and all 4 oxygen sensors also did the engine tune up. Now after clearing codes and unplugging the battery I’m receiving Codes p2096, p0133, p2096p... I keep erasing the codes and unplugging battery the same 3 codes keep coming back I don’t understand why. Can anyone help me please?
 
1 - 5 of 5 Posts
Top