Charger Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
What's up all. Quick question. I have a 2013 R/T Blacktop that I picked up in April. It's been what - 8 months and yesterday I get the check engine light. I was going in for an oil change anyway, but when I got to the dealer, the light shut off on it's own but they checked the car's computer anyway. The error was: P0151 so they changed the oxygen sensor.

My question is - my car only has 4,344 miles on it. Isn't that way too soon for an oxygen sensor to go bad? Any answers would be greatly appreciated. Thanks.
 

·
Premium Member
Joined
·
8,140 Posts
Not a bid deal it could have been a damaged harness causing a short, the sensor could have failed. I would not worry about it. A car is a million parts from various manufactures, and parts fail sometimes early on. I would not consider this an indication that the car will soon begin to fall apart.
 

·
Registered
Joined
·
909 Posts
Could have just been defective. The factory oxygen sensors are made by Denso, and they make pretty very good O2 sensors. That's not to say that they don't make defective ones though. Like anything you buy there's always a chance that the part is bad. Nobody's perfect. I wouldn't worry about it. My Dad's GMC Sierra had an oxygen sensor go bad at like 30k miles a few years back. Truck has 85,000 miles on it now and hasn't had another sensor go bad yet. It happens.
 

·
Registered
Joined
·
909 Posts
Double thread post...
 

·
Premium Member
Joined
·
17,450 Posts
No need to post the same question twice in different areas. Folks will see it and answer. Everyone here is pretty good about responding to a request for assistance regardless of the year of the Charger or where it's posted. :)
 

·
Premium Member
Joined
·
11,698 Posts
threads merged
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Oh sorry guys I didn't mean to post it twice. I saw the 2011+ forum after and I thought I had originally posted in the wrong area. Sorry about that. And yeah, I guess sometimes new products come defective - thank god for the warranty! Hopefully it was just 1 isolated issue from the factory and not a sign of any bad luck to come.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top