Charger Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
battery kept dying everyday, fixed it. the battery went about 5 days no issues then it wouldnt fire up, tested the battery and its fine so i figured it was the starter so i replaced it, now that ive got'er rammed in there and hooked up im still experiencing the same issue, wont even crank it. ive replaced the fuse for it still nothing ive tried jumping the car also nothing. what could be the issue after that? ive seen guys say the alternator but i don't wanna be out for even more money without knowing its gonna work. in case im not explaining this well enough my issue is basically the same as demonstrated here
dont waste your time watching the whole thing just watch the part where he attempts to start it
 

·
Registered
2019 Scat Pack
Joined
·
1,122 Posts
Charge the battery fully up, start it, and see if you're getting 14.5 or so at the terminals. If not, the alt is bad. Don't places like Autozone check them for free?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Charge the battery fully up, start it, and see if you're getting 14.5 or so at the terminals. If not, the alt is bad. Don't places like Autozone do it for free?
if the alternator was bad would it throw up an engine code? I have an old code reader I could look at
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Update: the battery terminals were shitty, dealership charged me 800$ to re sder the wires and reset over 80 codes on the car
 
1 - 6 of 6 Posts
Top