Charger Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 · (Edited)
I took my car the track today. I first ran it with the Predator Computer and went 12.821 @ 109.12 with a 1.951 ft. My 0 to 60 timer recorded 4.78.
I then switched my computer and put in the B&G. Every time it would shift from first to second it would hit the rev limiter. With the B&G i ran 12.94 @ 109.24 with a 2.013 ft. It went 0 to 60 4.85 . So i now decided to switch back to my Predator and i even add more timing in every gear. The car sat for at least an hour and half before i was able to go back up and run it. I ran a 12.791 @110.98 with a 2.028 60ft. The 0 to 60 timer was 4.67. I did notice that the car felt like it bogged a little on the take off and when it shifted from second to third it felt like it just slipped into 3rd gear. I think if it left a little better on that run it would have run at least 12.5 or better. It would not do as good as it did 0 to 60 when i ran it at night when it was cold. It went to to 60 on Wednesday night in 4.18 and i even babied it off the line because it was so cold. I also weight my car with a 1/4 tank of gas and it weight in at 4280 lbs and 4510 with me in the car. Now my next step to put on PPP heads and cam.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #3 ·
2 degrees on top
 

·
Registered
Joined
·
3,905 Posts
That run where it felt like it slipped from 2-3....did you get up to 20mph AFTER startup and have it shift into 3rd or was that the FIRST time it shifted into 3rd was during that run (after start-up).

If it was the first time, that was the dreaded "diagnostic shift" I always refer to.
 

·
Registered
Joined
·
1,828 Posts
Wait this reminds me of a post somebody made on here stating that the predator made less power than the B & G......
 
1 - 6 of 6 Posts
Top