Charger Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm new to the forums but looking for help, have a 2006 charger r.t 5.7 rebuilt with new bigger cam, couldnt tell u much about the cam I didnt do the build, took to several shops the car runs good according to them but continously stalls out when attempting to put in drive or reverse after driving for about 20 min.. everything is stock accept cam, has CAI, flowmaster mufflers, 2in pipes from cats, and recently bought diablo T2 waiting for it to arrive, also wanted a 90mm throttle body and new intake but open to advise befr committing
 

·
Registered
Joined
·
3,452 Posts
Welcome to the forums. Sorry, I have no suggestions but hopefully some of the members with cam experience will respond soon.
 

·
Registered
Joined
·
1,929 Posts
Definitely don't do any more mods until you get it running properly.

It you don't know the specs on the cam, you need to get them. Then check over the engine carefully to make sure all your vacuum, make-up air, PCV and EGR lines are hooked up correctly and not cracked or split.

Next, I'd definitely put an advanced scantool on it and check for DTCs.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Had it a 3 different shops for over the last 2 months no check engine, no other issues, no vac leaks, but the egr has ben deleted completely but not throwing codes, according to all 3 shops the car is top shape and was built properly and runs great other then the stalling issues, and I'm not sure other then tearing the engine dwn again on how to get cam specs
 

·
Registered
Joined
·
586 Posts
The cam wouldn’t cause the motor to die after 20 minutes of running.
Sounds more like a fuel pump problem to me.
I would hook a pressure gauge to the fuel rail and just let the car sit and idle for 30 minutes and watch the gauge.
I know this as I had a car that ran fine and would just quit running while driving.
I finally put it on a lift and let it run till it stalled and low and behold I could watch the fuel pressure drop causing causing the problem.
If you had a cam problem it would run like crap all the time.
 

·
Registered
Joined
·
2,707 Posts
hook a pressure gauge to the fuel rail and just let the car sit and idle for 30 minutes and watch the gauge.
Fuel system pressure should be 58 psi (± 5 psi)
.
 

·
Registered
Joined
·
5,599 Posts
Even bone stock early LX cars were plagued with random stalls. Do some searches here for potential culprits. I also remember the fuel tank being a common theme.

Best,
 

·
Premium Member
Joined
·
3,971 Posts
Be careful with the Trinity programming device. With a cam, your car will already be running a custom tune. You can't just upload any other "canned" tune from the Trinity because they won't have the customization you're already running. You can take your tune into the Trinity and modify some basic settings then send it back though.

If you can reproduce the issue, it may be worth working with a tuner to log what's happening before the stall and they may have some insight.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #12 ·
Fuel pressure is running at 56psi constant fluctuating 2psi just got it back from shop again at 330 today, the only thing they suggested was the car needs a computer tune due to having a slightly bigger cam, soo still no luck from 3 local shops, n.e other ideas guys?
 
1 - 12 of 12 Posts
Top