Charger Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
ok guys..i recently bought my first charger..an 06 RT,44k miles...it runs strong..couple things im starting to notice..at times when im really accelerating from stand still i let off completely and it seems to stay stuck briefly when its decelerating.it shifts very smoothly all the time with the exception of this..and it only does it at really high performing times..like 0 to 70...transmission trouble?or is this just a charger thing?
next.
at times when i start my car i get some vibration from the exhaust..its a very light rattling..almost sounds like tiny pieces of metal running down and out thru my mufflers..very very faint..im the only one that actually hears it..i cut my mufflers and resos off and added flowmaster 44s and i still hear it..heat shield loose somewhere?

lastly..i get light squeeking from my breaks at mid pressure..not all the time..are chargers normally this noisy?

thanks for the help.

:beer_yum:
 

·
Registered
Joined
·
58 Posts
I had the same issue with the brakes at light pressure. I tried cleaning, greasing, and applying disc brake quiet spray and bedded the brakes twice; which only temporarily fixed the problem. I then decided to replace the front brakes with Duralast Gold Cmax, turned the rotors, and repeated the above procedure and this fixed the problem; quiet as a monk now. these threads helped a ton:

http://www.chargerforums.com/forums/showthread.php?t=72911

http://www.chargerforums.com/forums/showthread.php?t=65669
 

·
Registered
Joined
·
1,878 Posts
My car also does the thing where it kinda gets stuck when decelerating but I dont think its anything bad and my exaust does the exact same thing, but I think it might be a broken weld.
 

·
Registered
Joined
·
1,055 Posts
Welcome to the Forums from Chicago! You have a Great car! It's just well seasoned. Hope you work out the quirks. Enjoy!
 

·
Registered
Joined
·
58 Posts
thanks man..im glad i decided to jump on here.i will get that done asap..you got an RT?:bigthumb:
Yup, got 24,000 miles and enjoying it every bit. Have fun learning all the neat tricks you'll learn in this forum!
 

·
Registered
Joined
·
1,037 Posts
ok guys..i recently bought my first charger..an 06 RT,44k miles...it runs strong..couple things im starting to notice..at times when im really accelerating from stand still i let off completely and it seems to stay stuck briefly when its decelerating.it shifts very smoothly all the time with the exception of this..and it only does it at really high performing times..like 0 to 70...transmission trouble?or is this just a charger thing?
next.
at times when i start my car i get some vibration from the exhaust..its a very light rattling..almost sounds like tiny pieces of metal running down and out thru my mufflers..very very faint..im the only one that actually hears it..i cut my mufflers and resos off and added flowmaster 44s and i still hear it..heat shield loose somewhere?

lastly..i get light squeeking from my breaks at mid pressure..not all the time..are chargers normally this noisy?

thanks for the help.

:beer_yum:
The exhaust tinging (like metal running down) is normal. Mine does it.

Brake squeaking and squealing is pretty much an on going battle with our cars. Our cars are big and heavy and they beat the crap out of the rotors and pads. I went from stock to Centric Rotors with Raybestos Pads. They squeek a little but not annoying enough to replace.

As far as the transmission, are you saying that the transmission downshifts to slow you down during hard braking? If so, this is normal.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
update

i went to get my front brake pads replaced and rotors machined, after looking at my brakes the mechanic says i have 3/4s of my pads left..that my brakes look fine. He said i didnt need to replaced..he said that the squeek is from a glazed over my rotor after continued driving, that if i replaced them it would start again after a little while..i am very surprised..i was certain there was something wrong..
and the throttle seems to hang for a sec when i let off the gas after i romp on it..just briefly..like in downshift..without braking.

also.does anyone know if RT grill emblems fit non honeycomb grills, i have the regular straight grill and want the RT on the front..thanks

had my exhaust looked at as well..they couldnt find anything wrong...hmmm. guess ill wonder..

thanks all.
 

·
Registered
Joined
·
2,069 Posts
Mine also has that heat sheild rattle sound, but could never find anything loose. I suspect it's in the cats that are causing it.

Try driving your car only with the auto stick for a few days. And be aggresive with it. After a few days, drive in auto and you noticed a huge difference on how the tranny acts.
 
1 - 10 of 10 Posts
Top