Charger Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
712 Posts
Discussion Starter · #1 ·
Well my first run with the Charger was pretty good except my 60's were for sh*t. My first run I caught a .009 reaction time 2.1, 60' and ran 12.8 @ 111.16 mph with my rear Vred at 28 psi, second run 2.0 60' and 12.9 @110 mph with the rear Vred at 24 psi, third run I bumped my tired psi back to 35 to keep the top end because I felt the low psi was holding me back on the top end and my 60' was not getting any better and ran a 2.0 60' and 12.6 @ 111 mph.


All runs on 315/35/20 rear Vreds no water box no burnout, full street trim no weight reduction what so ever. I know she has ALOT more in her if I can get the 60' down to 1.7-1.8, so it looks like its drag radial and torque converter time. Anyone want my stock rear end

All in all im pretty happy with how it went.
 

·
Registered
Joined
·
1,391 Posts
man that really isnt bad at all, if you could get the first 60 down without much spin, but with street tires it tsnt going to happen. still great time
 

·
Registered
Joined
·
712 Posts
Discussion Starter · #4 ·
man that really isnt bad at all, if you could get the first 60 down without much spin, but with street tires it tsnt going to happen. still great time
I tried mashing it, feathering it off the line and I was still getting a very small wheel hop as little as it was it cost me my 60', ran a super bee with almost the same mods but he had a converter which I do not, he was on stock rims and tires and a stock open diff, I have the USW's heavier then stock rims, Vreds, Getrag 3.06 LSD and no converter, we both had heads and cam work. He heated his tires up I did not, all factor into the ET his MPH was 114 to my 111 so looks like converters do work.

Nice runs, did you go to e-town?
Yes we went to Etown and thanks!
 

·
Registered
Joined
·
99 Posts
Congrats, I've taken my Charger to the track only once and managed the 12's as well!
 

·
Premium Member
Joined
·
1,196 Posts
dang... good times for being on street tires...!
Good job !
 

·
Registered
Joined
·
14,728 Posts
i've felt the same way in my r/t. i've done low psi to launch better but the car gets too squirrely around 90 mph and it feels like it slows me back down. I'm gonna run slightly higher psi next time.
 
1 - 7 of 7 Posts
Top