Charger Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
252 Posts
Discussion Starter #1 (Edited)
I discovered some new things on my '08 R/T:

1. In Fuel Saver mode, the letters 'FS' shows at the top left corner of EVIC temp display. I asked around and people said this was not in the '07s.

2. I was travelling at 87mph on the freeway and if I kept my foot on the gas pedal steady, 'FS' would show on my temp display. I searched through some old posts and read that MDS was not active at high speeds.

Addendum: This is not new in '08s. Sorry for the wrong info. I didn't read enough. MDS is dependent on many things but not limited to a certain speed.

3. My fuse box up front is different that previous models. There's a lot fewer fuses. The fuse 11 on 05-07s is now fuse 2 on mine.
 

·
Registered
Joined
·
3,862 Posts
2. I was travelling at 87mph on the freeway and if I kept my foot on the gas pedal steady, 'FS' would show on my temp display. I searched through some old posts and read that MDS was not active at high speeds.
It's not exclusively a speed issue... I think it's all about the PCM calculated load. That means it'll be a function of MAP, air temperature, pedal position, etc. Put your EVIC in diag mode and look at the pedal positions necessary to get MDS to kick in at those speeds: my guess is that it'll hold MDS until 25% or so, but probably not on an incline with the car slowing down.

I've had MDS on at an 85 MPH cruise with 4 people in the car but it was damned cold that morning! (ie. really dense air).
 

·
Registered
Joined
·
1,927 Posts
That's pretty cool, so it tells you that you are saving gas. The should add WOT on the EVIC for us spirited drivers :grin:
 
1 - 3 of 3 Posts
Top