Charger Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter · #1 ·
Okay, So the other day I removed my wheels and coil overs in the front end to attempt to change my springs but didn't have a spring compressor. So I then put everything back and tight just the way I found it.

Now for some reason my steering is messed up now. When I now drive my steering wheel shakes back and forth. Its not something anyone could ignore. Its VERY drastic. Its not much of a problem until I start to go over 25mph. On the roll the wheel doesn't shake but as soon as I put my foot on the throttle the wheel just looses it.

Something Ive noticed is that when ever I pull out my driveway and my car drops off the curb I hear a CLUNC in the front right end like something is loose. But I looked and double checked to make sure everything is in tact and tight and I don't see anything wrong. So right now my car is not drivable.

HELP PLEASE.
 

·
Registered
Joined
·
1,711 Posts
If you put everything back the way it was, then you shouldnt have a problem. Lug nuts tight?
 

·
Registered
Joined
·
13,502 Posts
Loose tierods or steering rack ?


* subscribed *
 

·
Registered
Joined
·
223 Posts
Are you running directional tires and put them back on the wrong side?
 

·
Registered
Joined
·
126 Posts
Okay, So the other day I removed my wheels and coil overs in the front end to attempt to change my springs but didn't have a spring compressor. So I then put everything back and tight just the way I found it.

Now for some reason my steering is messed up now. When I now drive my steering wheel shakes back and forth. Its not something anyone could ignore. Its VERY drastic. Its not much of a problem until I start to go over 25mph. On the roll the wheel doesn't shake but as soon as I put my foot on the throttle the wheel just looses it.

Something Ive noticed is that when ever I pull out my driveway and my car drops off the curb I hear a CLUNC in the front right end like something is loose. But I looked and double checked to make sure everything is in tact and tight and I don't see anything wrong. So right now my car is not drivable.

HELP PLEASE.
You were able to remove the coilovers without a spring compressor?
What exactly did you uninstall/reinstall?
Upper control arm, endlinks?
 

·
Registered
Joined
·
1,748 Posts
im betting its you cv axle... get it checked out and make sure they inspect under teh booth as thats where you will be able to see the issues at hand.. cheap i think only like 75 total without out labot
 
1 - 9 of 9 Posts
Top