Charger Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter #1
Hi all, i've had my charger for about a year now and I absolutley love it. But this morning as I drove to work, I noticed both at 50km/h and at 10km/h that there is a slight squeaking or chirping noise in my front drivers side seeming to originate from the rotor or tire. Now about 4 months ago I brought it for the MVI and they replaced the brake pads with these horrific ACDelco pads that just screech when I lightly apply the brakes and brand new rotors. I've checked the rotors for unusual wear and damage but cant seem to find anything and at the times I was hearing this chirping/squeaking i wasnt braking.

I started to think it could be a lug nut that's come slightly loose but I saw the tech put on the tires and tourque them to spec when I changed to my summers a few months before the MVI. But that leaves the question, did the guy from Chevy torque the wheels right? (I bought it second hand from a chevy dealer and had a thorough look over at it before buying it and got an extended warranty)

Right now I really think it could be a loose lug nut but I really don't know what else it could be. :\ Any help or pointing in the right direction would be much appreciated. Thanks in advance :D
 

·
Registered
Joined
·
149 Posts
man I got that same thing but thought it was my breaks so I turned up the radio.
Have no clue.:confused:
 

·
Registered
Joined
·
281 Posts
Discussion Starter #3
Well, tomorrow im doing my oil change and i'll prolly lube the brake guides and caliper contacts and such just to try and reduce the brake screech and ill retourque the wheels to make sure its done all right xD.
 

·
Registered
Joined
·
1,416 Posts
If you used semi-mettalic pads,thats your problem ,you should have used ceramic pads if you dont want screeching noise.
 

·
Registered
Joined
·
281 Posts
Discussion Starter #5 (Edited)
I didn't put the pads on, they replaced the pads when I got the MVI done (window lickers that put them on prolly ordered the semi metallics, all I saw was an ACDelco box -_-; ) . The main problem isn't the screeching from the brakes though, but a chirping from the wheel when brakes aren't applied and both at city speed and a moving idle. It's not a constant and not real noticeable
 
1 - 5 of 5 Posts
Top