Charger Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have an iTouch 2nd generation and a 2009 Dodge Charger R/T with the stereo/mp3/cd player (not the MyGig). Using the connect cable in the glove box that came with the car it won't charge my iTouch.

Has anyone else had this problem and know of a possible solution? I asked the local service people and they weren't of any help.

As well, since I updated it to 3.0, the connection is unreliable, but I can get it to connect. The charging issue has been since day one though.

Thanks!
 

·
Registered
Joined
·
8,719 Posts
they changed the plug for the new itouch/iphone. the older ipod charger (like the integration kit in your glove box) is the wrong one. You may be able to find an adapter. maybe call apple?
 

·
Registered
Joined
·
1,729 Posts
check the different itouch adapters with the mopar guys.. maybe they can help
 

·
Registered
Joined
·
1,272 Posts
Like the above stated, most anything made before this version came out won't charge your ipod.... I have run into the same thing with my iHome and my adapter. It's a bummer.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Adapters

On another forum I found an adapter that is supposed to be able to make it so my iTouch will at least charge. I'm not sure if it will resolve the connection issues I'm having as well.

Scoche passPORT iPod USB Car Adapter $39.99 CDN at my local Futureshop

I also got in touch with Chrysler Canada and they are looking into whether or not the 2010 models will have updated cables. If they do, then I will probably just wait for one of them. They're supposed to get back to me today.

Thanks for everyone's input!
 

·
Registered
Joined
·
1,272 Posts
I also got in touch with Chrysler Canada and they are looking into whether or not the 2010 models will have updated cables. If they do, then I will probably just wait for one of them. They're supposed to get back to me today.

Thanks for everyone's input!
Let me know what they say!
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Chrysler Canada called me back this morning. They weren't of any help, but they did provide some information.

There currently is no fix for the connectivity problems people may be having with version 3.0 of the iTouch/iPhone software. A representative from the manufacturer of the stereo decks is supposedly flying to California next week to meet with people from Mac in order to discuss the problems they are having. So they are obviously aware of the issues, but we may not see a resolution any time soon. Any likely software fixes would come in the form of software updates from Mac, and not from the stereo makers.

Mac just released a software update, 3.1.1 for iTouch/iPhone. I installed that this morning, maybe it will fix the problem? I haven't had a chance to test it thoroughly yet.

As far as charging goes, I guess we'll have to pick up an adapter if we really want to charge our newer model iTouch/iPhones/iPods in our cars. Or wait until the 2010 cars come out, assuming they get updated cables.

------

Dodge Charger R/T 5.7L V8 Hemi - Torred
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Update

Today I broke down and bought the $40 charger. It works. As well, the update to the 3.1.1 seems to have fixed the glitches I was getting on connection.

In summation, it all works tickety-boo!
 
1 - 8 of 8 Posts
Top