Charger Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,729 Posts
Discussion Starter · #1 · (Edited)
Hi everyone!

I really need your help... I started to feel a weird "shake" , but not from my engine (I can feel the engine is fine, and no revs problem)... is like if the street is in bad shape, like a very little ocean weaves, between 25 and 35 mph...

First, I thought was the pavement, but not... I was driving 30 mph and I removed my foot from my gas pedal and I feel it again (in D, automatic)

can be a tranny problem??? brakes/rotors problems???

please help me guys, I´m very sad :(

thnx! btw, in my 3.5 HO v6 with 5 autostick

Btw, no codes :s
 

·
Registered
Joined
·
13,502 Posts
You may be feeling torque converter shudder .....

How many miles on your ride ?

have you ever had the fluid changed / flushed ?
 

·
Registered
Joined
·
1,729 Posts
Discussion Starter · #3 ·
29100 miles, and i cant remeber if i changed the oil, the dealer always do the service as the manual said.
 

·
Registered
Joined
·
1,998 Posts
29100 miles, and i cant remeber if i changed the oil, the dealer always do the service as the manual said.
It's still under warranty. Take it to a dealer ASAP and let them check it out. The tranny fluid usually doesn't get chg'd until 60K miles. You might want to have it checked for the infamous O-ring leak. Have you noticed any fluid puddles under the car? Have you gotten any fault codes?
 

·
Registered
Joined
·
1,729 Posts
Discussion Starter · #5 ·
Thnx for your advices!!

Nope, no codes and no leaks. The dealer changed the o ring 2 years ago lol.

I talked to the service manager, he wants to drive and check by him the car, tomorrow. I'm very nervous, dont want to have a tranny problem :(

and yes, i still have the warranty 7 years :D

what could be?? Sometimesi felt, sometimes not
 

·
Vendor
Joined
·
10,366 Posts
Thnx for your advices!!

Nope, no codes and no leaks. The dealer changed the o ring 2 years ago lol.

I talked to the service manager, he wants to drive and check by him the car, tomorrow. I'm very nervous, dont want to have a tranny problem :(

and yes, i still have the warranty 7 years :D

what could be?? Sometimesi felt, sometimes not
Sounds like torque converter shudder to me as well. Generally the fluid in these transmissions start to lose their friction modifiers and they tend to have some "chatter" between shifts because of not smooth engagement.

A fluid change would be in order and see from there how it responds. I have had some customers that have the notorious 604 shudder between 30-40.

I made them a QuantumBlue ATF+4++ Trans fluid that when flushed and driven, it took about 100 miles before it calmed down.

Definitely get it to the dealer. I believe these transmissions are costly to replaced at the dealer. Good luck.:beerchug:

Thanks
Brian
BND Automotive LLC
440-821-9040
 

·
Registered
Joined
·
919 Posts
I have 53K miles and I've noticed this at 35-40 mph as well, changed the O-Ring 3 years ago. I never noticed it until I swapped my brake pads 2 weeks ago.
 

·
Registered
Joined
·
1,729 Posts
Discussion Starter · #8 ·
I have 53K miles and I've noticed this at 35-40 mph as well, changed the O-Ring 3 years ago. I never noticed it until I swapped my brake pads 2 weeks ago.
and still have that weird feeling??
 

·
Registered
Joined
·
919 Posts
It's not very noticeable, only if I accelerate moderately.
If I get up to 30 then hit the pedal hard until 40-45 it's not there.
 

·
Registered
Joined
·
1,729 Posts
Discussion Starter · #10 ·
Guess what... I came from the dealer, the service manager checked all, and he drove the car and he said: the tranny is fine, engine is fine... Lets check the tires. And yes!!! The rear tire (right) has an imperfection so i need to check it with continental if the tire can be changed by warranty.

Thank god!! Is only a tire and not the tranny!!

Thnx all the friends who read and post info in this thread!!!
 
1 - 10 of 10 Posts
Top