Charger Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6,117 Posts
Discussion Starter #1
hey guys,

doing the front spring change and well me and the car are having a hell of a time understanding each other....the upper A frame will not seperate..i have taken off of the big bolt but the threads will not seperate through the hole...what am i doing wrong...i have a pickle fork and it just isn't working and i have torn the damn bushing ( i think that is the correct term..the plastic piece holding in grease)...i am fluster any help would be appreciated
 

·
Registered
Joined
·
6,117 Posts
Discussion Starter #2
does that big screw need to be threaded through the A frame hole or just pulled apart?
 

·
Registered
Joined
·
6,117 Posts
Discussion Starter #3
ok after a two hour struggle the hostage crisis is now over...i have the strut..i say again i have the strut...

bad thing about having off...no one to talk to right now...but i have solved my problem - i beat like it owed me money
 

·
Registered
Joined
·
112 Posts
:clap: :clap: :clap:

To those who boldly go before us...

A salute.... Well that and an extra pint next time at the pub.

:clap: :clap: :clap:
 

·
Registered
Joined
·
6,117 Posts
Discussion Starter #5
i am a master..i mean this seriously man, after the first one taking literally half the day b/c of screw up after screw up - the second one up front took (not kidding) 15 minutes.

now that i know how to do it is a piece of cake.... i just needed to screw up like it was going out of style.....trust me - if it could go wrong it went wrong!!!!

and if i am ever in mn. i will look you up for the extra pint!
 
1 - 5 of 5 Posts
Top