Charger Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2006 SXT, I absolutely love it but in the last 2 months I have had it at the shop 4-5 times for the check engine light. The first time was a sensor for the temp of the engine, the second time the thermostat had snapped. Once I got it back from that, the light came on the very next morning after just 5-7 minutes of running. I was told the engine temp hadn't even reached 150 degrees yet. They reset it, kept it a couple of days, but no luck it didn't happen again. I then went to Florida for a week in the car, came back and drove it to work (which is one hour one way), and 4 days after our return, it comes on again, same situation same code. Engine only 152 degrees and they have not had any other charger to have this problem. If anyone has experience this please email me @ [email protected] as I have been laid back about it so far but I am also ready for this to be resolved.
Thanks!:confused:
 

·
Registered
Joined
·
3,212 Posts
Sounds like a bad thermostat again. Is it a dealer doing the repair or a neighborhood shop? The NS might be putting in a substandard t-stat.
 

·
Registered
Joined
·
642 Posts
I have a 2006 SXT, I absolutely love it but in the last 2 months I have had it at the shop 4-5 times for the check engine light. The first time was a sensor for the temp of the engine, the second time the thermostat had snapped. Once I got it back from that, the light came on the very next morning after just 5-7 minutes of running. I was told the engine temp hadn't even reached 150 degrees yet. They reset it, kept it a couple of days, but no luck it didn't happen again. I then went to Florida for a week in the car, came back and drove it to work (which is one hour one way), and 4 days after our return, it comes on again, same situation same code. Engine only 152 degrees and they have not had any other charger to have this problem. If anyone has experience this please email me @ [email protected] as I have been laid back about it so far but I am also ready for this to be resolved.
Thanks!:confused:
do you know what the code is for like to hot to cold etc
i know also from changing my upper hose that when you refill system there is a bleed on top of intake to prevent air pocket
 

·
Registered
Joined
·
112 Posts
I know this doesn't help.... But thats one of the few things I HAVEN't had the car in the shop for!:(
I'm sure it's coming though..

Macker
SLC, Utah
 
1 - 4 of 4 Posts
Top