Charger Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2007 Dodge Charger 3.5 -
I have heat when engine is more than idle ... At idle it is like luke warm/cool I have burped system several times still the same . changed cap as seal was cracked same , inlet heater hose hot outlet warm /cool until I give more rpms then there is heat . { Blasting heat when driving at 55 } Hardly any heat at idle .


I have been told it is the Water pump / Air in sys or the Oil Cooler that is above the oil filter { on 3.5 } that gets white contamination in it from AF and causes blockage and poor circulation to heater core at idle ?
Takes forever for temp to get to operating temp when cold out ? No overheating issues .
Your opinions ? Thermostat ? Oil cooler ? Water pump ?
Thanks ,
& Merry Christmas ! & Happy New Year !
 

·
Premium Member
Joined
·
17,450 Posts
Flush the old coolant and replace along with thermostat. Remove all air properly. If symptoms persist, replace water pump.

You described all of the advice in your post.

Just do it.
 

·
Registered
Joined
·
5,852 Posts
It is usually the thermostat when the engine won't heat up normally. That being said, have you had the timing belt changed yet? The belts are only good for 7 years / 100,000 miles, so you are way overdue on time alone.

When the belt wears it doesn't spin an old water pump with a bad bearing worth a damn. If it hasn't been done yet, I'd change the belt, water pump, and thermostat all at the same time.
 

Attachments

1 - 3 of 3 Posts
Top