Charger Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Heated Drivers seat doesnt work,turns on and after about 3 to 5 seconds it kicks off,passenger one works
2012 Charger sxt
 

·
Premium Member
Joined
·
17,444 Posts
Heated Drivers seat doesnt work,turns on and after about 3 to 5 seconds it kicks off,passenger one works
2012 Charger sxt
Sounds like a short in the circuit.

The system is designed to kick off when the electrical resistance reaches a certain level. This is normally associated with the heat build-up that results in increased resistance telling the circuit controls that the desired temp has been reached.

If it kicks out early, it usually means there is a fault in the wiring that is causing resistance to increase prematurely. This is usually in the seat heating elements themselves, not in the feed wiring.
 

·
Registered
Joined
·
1,890 Posts
Plug a OBD2/CAN scan tool into the OBD2 port and see if any DTCs (Diagnostic Trouble Codes) are posted. There are DTCs for the switch, heater control, heated seat module, etc ... If any DTCs are posted they will give you a clue where to look (seat element, switches or the heated seat module).
.
 

·
Registered
Joined
·
3,195 Posts
My vehicle currently has the exact same issue as well.
I'm taking it in for my 50,000km service this Friday and will have them take a look at it, among other things.

Will let you know by then, if you haven't discovered the resolution already :)
 

·
Registered
Joined
·
2,390 Posts
How cold is it there? If you have the heated seat function engaged to turn on when the car is started and it is above 40 degrees it may turn off on its own because of the outside temp. being warm. Just a thought.

I have an issue with my seats not turning on when using the remote start on occasion in the winter. I simple have to turn them off then on again. Usually works. Hit and miss.

I haven't tried turning my seats on in warm weather so I can't comment as to if the thermostat is reading the outside temp and turning off the drivers seat.
 

·
Registered
Joined
·
3,195 Posts
If you have the heated seat function engaged to turn on when the car is started and it is above 40 degrees it may turn off on its own because of the outside temp. being warm. Just a thought.
That is what I thought initially..but then why would it allow the passenger side to run its course?
 

·
Registered
Joined
·
2,390 Posts
That is what I thought initially..but then why would it allow the passenger side to run its course?
If I'm remembering right. I think the drivers seat is the only one that turns on with the remote start. That would make it the only seat tied to the outside temp. thermostat. At least on my 2011 that's how it is.

Wondering if you would turn off the drivers seat auto on with remote start function in your uconnect comfort settings if your seat would stay on after manually turning it on?

Worth a try.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8 (Edited)
hi and thanks for the idea's,i tried your idea Playhard ,i was sooo hoping that would work but but it didnt.Thanks again everyone for trying to help !
 

·
Registered
Joined
·
3,195 Posts
Turns out they had to order some part to replace the heating pad/element that is located beneath the driver seat cushion.
I do not have a part number yet..but should have access to it when they call me in to have it replaced.
 

·
Registered
Joined
·
10 Posts
Hey Powerman! I was just wondering how you made out with your heated seats after you took it in? I'm currently having the same problem and wondering if its something I need to take it in to the dealer to get fixed. Any info would be appreciated. I'm trying to get it done while still under warranty and before it's freezing out. Thank you!
 

·
Registered
Joined
·
2 Posts
Just saw this when researching for someone with a similar problem. Thanks. Just found out I need to replace mine as well. I only have 39742 miles on my 2014 Charger. Besides that I have a noise coming from my front left wheel when I make right hand turns. Dealership told me its my left front wheel hub bearing. Go figure. Thank goodness for Extended Warranty!

Sent from my SM-N910P using Tapatalk
 

·
Registered
Joined
·
58 Posts
I've had the same problem for over a year as well. Not normally an issue for most for most of the year so it's easy to put off the repair. I did have the dealer investigate it a while back and they also came back with the same conclusion, needed to replace driver side heating element. I think it was like $500 parts and labor. No thanks. But being in Wisconsin, I definitely wanted this option when I purchased the vehicle. Is this a fix that can easily be completely? Its not the parts that concerns me, its how much demo that may need to be done to drivers seat to get at it. Anyone ever undertake this operation?
 
1 - 16 of 16 Posts
Top