Charger Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,262 Posts
Discussion Starter · #1 ·
I just need to get this off my chest, It might be more of a rant but it needs to be said.

Just last Friday, My car started to make this weird noise coming from my rear passenger side( a grinding noise/ which stops when I tap on the brakes). Every time I start drive the grinding noise just started to drive me nuts so I take it to my dodge dealer which does my routine maintenance all the time and have them look it. They had my car for a good 3hrs and come and tell me that a bolt was loose in the rear suspension which caused the noise. I was kind of spectacle about this at first but left it alone and paid the invoice. The noise stop, so I thought it was the bolt they found...........

UNTIL yesterday morning. On my way into work the grinding noise came back. :icon_mad:

Today, It got so bad that I just took it in to my local Goodyear to put it on a lift and see if they see anything unusual. Once they put it on the lift they come back immediately and call me to my car and was shock on what I saw and what they pointed out.

Come to find out my rear inner pads are shot on the inner side and are already hitting metal to metal on my inner rotors which are also shot now. The rear passenger side are metal to metal but my rear driver side still has some life but barley.

Why didn't Dodge see this and warn me about this when they do my routine maintenance and when I took it in last week? When I saw it under the lift it was obvious of the wear and the metal to metal on the rotor since a deep ring engrave already started to be visible on the rotor from the pad.

The thing I don't understand is that when I stop or hit my brakes I didn't hear any squealing or grinding. Everything seemed normal until that noise started last week when I drive.

Now i just ordered some premium slotted rotors from R1 C, and waiting for them to come in this week. This is just ridiculous :scratchhead: why Dodge didn't warn me about this well before in advance before it got this bad.

OH....... :argue:


forgot to mention that my Tie rod end on my front passenger side is going bad as well......But Dodge don't want to tell me this as well.
 

·
Registered
Joined
·
2,924 Posts
It does make you wonder. Seems pretty damn basic for a "certified" mechanic to over look it.
 

·
Registered
Joined
·
1,454 Posts
Sounds like a caliper locked up, that's why no noise when you applied the brakes, only when driving. On the bright side your MPG's should improve....
 

·
Registered
Joined
·
1,878 Posts
Wow what a bunch of A$$ hats! They should be fired.
 

·
Registered
Joined
·
115 Posts
I had a similar sounding issue except mine was from the fronts. I told them it sounded like a brake issue or caliper. They called me a few hours later and said my heat shield was flapping in the wind and that reinstalling the stock exhaust is the only fix. I talked with the guy and said metal flapping against metal and the noise I was describing are two vastly different sounds. They said no it is that so I took my car and will try never to take my car there again unless I absolutely have to.
 

·
Registered
Joined
·
9 Posts
IF THEY TOLD YOU ONE THING, AND "FIXED IT" THEN SHOULDNT THE DIAGNOSTIC ON THE INVOICE YOU PAID BE GOOD FOR 30 DAYS? IF SO THEN IT SHOULD BE COVERED FOR THE SIMPLE FACT THAT THEY TOLD YOU xxx WOULD FIX IT AND IT DIDNT. EVEN IF WARRANTY OR WHATEVER DOESNT COVER THE "CURRENT" ISSUE, THEY TOLD YOU THE BOLT WAS LOOSE, AND IT MAY HAVE BEEN BUT IT DIDNT FIX THE ISSUE, LEAVING THEM AT FAULT FOR NOT TELLING YOU ABOUT THE OTHER STUFF.



oops sorry bout caps....
 

·
Registered
Joined
·
176 Posts
hmmm hence bankruptcy...maybe that dealership should of been on the list of places to close.
 

·
Registered
Joined
·
1,238 Posts
Thats why I do ZERO maintenace at the stealership. Overpriced ****ty service.
 

·
Registered
Joined
·
1,975 Posts
I have something like that, might have to look into this. I have a light grinding noise when i roll slowly but when i push brakes its gone and when i accelerate to a higher speed i can't hear it.
 

·
Registered
Joined
·
115 Posts
I have something like that, might have to look into this. I have a light grinding noise when i roll slowly but when i push brakes its gone and when i accelerate to a higher speed i can't hear it.
That was my exact problem and once I got the brakes done it was nonexistent.
 

·
Registered
Joined
·
1,975 Posts
grrr i don't want to change the brakes haha
 
1 - 13 of 13 Posts
Top