Charger Forums banner
1 - 20 of 24 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter · #1 ·
So I got my high flow cats from Magnaflow today!!!:D

I am going to install them Monday morning. Before I do the install, I figured I would ask if there are any suggestions from you guys about it. Is there anything special I should do? What about the O2 sensors? Aren't there some codes I might throw? How do I avoid the codes.... etc.


I will post pics of the installation when I'm done.

Thanks...
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #3 ·
Ok, thanks...
 

·
Registered
Joined
·
460 Posts
which ones did you buy? Can I get the part #? Price? Etc...if you don't mind? Have you got them installed yet?

thanks
Brian
 

·
Registered
Joined
·
3,168 Posts
the magnaflow high flows are for the 6.1
the JBAs are for the 5.7
just keep that in mind, as far as if you can put the 6.1's on a 5.7 and not lose performance(hell maybe you gain more) i do not know.

to my knowledge.
 

·
Registered
Joined
·
460 Posts
the magnaflow high flows are for the 6.1
the JBAs are for the 5.7
just keep that in mind, as far as if you can put the 6.1's on a 5.7 and not lose performance(hell maybe you gain more) i do not know. to my knowledge.
Didn't know that. Thanks. Can anyone answer that question. I thought I read some where on here that a guy put the Magnaflow's on his R/T? Could be wrong though.
 

·
Registered
Joined
·
474 Posts
no codes on my SRT so far.
 

·
Registered
Joined
·
1,655 Posts
Did you install them yet?
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #9 ·
So, I installed the Tuesday. I took some pics, but haven't had the time to do a write up on it. I'll try and get it together today. All went well, except the exhaust now hangs lower and we had to use washers to seperate the exhaust from the crossmember.
 

·
Registered
Joined
·
474 Posts
So, I installed the Tuesday. I took some pics, but haven't had the time to do a write up on it. I'll try and get it together today. All went well, except the exhaust now hangs lower and we had to use washers to seperate the exhaust from the crossmember.
i had this problem too. i installed the cats and corsa catback. and my cross member no longer fits. another member on 300cforums. said he took it to an exhaust shop and they were able to adjust everything so the cross member fit the way it should.
 

·
Registered
Joined
·
460 Posts
Can't find just JBA high flow CATS anywhere. Not listed on their website. I can not find Magnaflow CATS either for a Charger. Anyone help?
 

·
Registered
Joined
·
460 Posts
if you are talking about the kit that they sale they are JBA's for the 5.7's and Magnaflow's for the 6.1's
 

·
Registered
Joined
·
3,168 Posts

·
Registered
Joined
·
474 Posts
Can't find just JBA high flow CATS anywhere. Not listed on their website. I can not find Magnaflow CATS either for a Charger. Anyone help?
try tbyrnemotorsports.com
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #16 ·
I'm working on the write up, but today I got the P0430 code. What do I need to buy to fix this problem? I can't find the post about what fixes this.
 

·
Registered
Joined
·
3,168 Posts
did you disconnect the battery while youdid the install?

. if not go do that and then go for a spin and see what happens. your car will be angry if it remembers the other cats youhad, then it gets woken up to something totally different without having its memory wiped.
 

·
Registered
Joined
·
584 Posts
did you disconnect the battery while youdid the install?

. if not go do that and then go for a spin and see what happens. your car will be angry if it remembers the other cats youhad, then it gets woken up to something totally different without having its memory wiped.
HAL: YOU WOULND'T LIKE ME WHEN I'M ANGRY...
 

·
Registered
Joined
·
584 Posts
Will these work with a stock R&T exhaust? I see they are 3" before the cats and 2.5" after, but I though the stock exhaust on a 5.7L was 2.25". How do they connect?
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #20 ·
did you disconnect the battery while youdid the install?

. if not go do that and then go for a spin and see what happens. your car will be angry if it remembers the other cats youhad, then it gets woken up to something totally different without having its memory wiped.

i pulled fuse 11. That should have reset HAL, right?
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top