Charger Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter · #1 ·
So driving the Charger last night and around 50mph it goes into neutral while its in Drive?

So it stays in neutral until you slow down to about 30mph.

Anyone experience this?

What is it?
 

·
Registered
Joined
·
2,847 Posts
Sounds like a software glitch. The dealer should beable to flash your TCM for that
 

·
Registered
Joined
·
1,646 Posts
Hmmm, I'm not familiar with our chargers "limp mode" but sounds like that could be what's happening......
 

·
Registered
Joined
·
249 Posts
Discussion Starter · #4 ·
Sounds like a software glitch. The dealer should beable to flash your TCM for that
Yeah I was thinking it's something sensor relatated.....cause the rest of the car is fine...when it acts up nothing else is affected.....doesnt sound like it;'s gonna turn off or anything...........

Can anyone recommend a Knowledgeable dealer in Illinois?

The guys at the dealer I got to "Midway Dodge" Pulaski and Archer are nice but seem to be very simular to Alley Mechanics....which is fine as I am kinda one. :lol:

But since is thing cost a lot and has a warrenty and want to maxmize it. thanx
 

·
Premium Member
Joined
·
8,140 Posts
Let me know what you find out, my car did this today in the rain. I was crusing along and all of a sudden my rpms were bouncing off the limiter, slowed down to 30 hit the gas all was good, got back up to 50 and no gears. Since this happened on my lunch hour I have not been able to see what happens after a restart. I did not like this feeling at all
 

·
Registered
Joined
·
122 Posts
We have UPS package cars that are the Freightliner equivilant of the Dodge Sprinnter.

And both have had trany problems and that was what the limp mode was like. But the would only go up to 40 mph. Then they would cut out.

They had to go to the dealer for service, think one was the trany and the other was just a sensor.
 
1 - 6 of 6 Posts
Top