Charger Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Did anyone see ERROR in instrument cluster display where you would see
mileage in dodge charger 2014?
I took it to my dealer and they said I need to replace my instrument cluster
and I need to pay for that. And I did got it replaced but same thing happened
again in couple weeks of replacement and they replaced another instrument
cluster.
Now, I again see 'ERROR' display in instrument cluster! They're trying to figure out the issue.
Does anyone heard about this issue?

Thanks!
 

·
Premium Member
Joined
·
2,075 Posts
RT:
It seems they have not yet found the problem, only one of the symptoms. The good news is that you have a 12mo/12K warranty on that repair, so it should not cost you anything beyond what you have already paid.

Sounds frustrating!

Don
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
RT:
It seems they have not yet found the problem, only one of the symptoms. The good news is that you have a 12mo/12K warranty on that repair, so it should not cost you anything beyond what you have already paid.

Sounds frustrating!

Don
Thanks for the reply Don.

Yeah it is frustrating!
I feel like it's not even related to Instrument cluster and I've paid for a new instrument cluster for nothing!

~
Ravi
 

·
Registered
Joined
·
4,249 Posts
Thanks for the reply Don.

Yeah it is frustrating!
I feel like it's not even related to Instrument cluster and I've paid for a new instrument cluster for nothing!

~
Ravi
Yeah, I'm sure it does feel that way, but the fact that your having the issue still, and they have to do more diagnostics for free should be comforting somewhat.. sort of.. There's a problem somewhere.
 

·
Registered
Joined
·
1,287 Posts
No clue if this applies here, but on older Chrysler vehicles, if you'd get a "no bus" message in the odometer window it was because the cluster wasn't able to communicate with the computer and it was usually the computer that was the issue.
 

·
Registered
Joined
·
418 Posts
I would bet it is the Body Control Module (BCM). The dealership should have checked before charging for a new cluster.
 

·
Premium Member
Joined
·
1,139 Posts
It sure seems EXTREMELY unlikely it was your instrument cluster when three of them have done it now. I would at least be trying for a refund on the instrument cluster.

Dodge Cares, are you out there???
 

·
Registered
Joined
·
1 Posts
Aftermarket?

Are you using any aftermarket accessories on the bus that may be affecting operation? I have seen when programmers or other things are plugged into the OBD port strange things can happen. Especially on a PowerNet bus system.
 
1 - 8 of 8 Posts
Top