Charger Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2007 Charger SRT.
Recently my alternator went bad and I had it replaced. Being my battery was the original I replaced that as well.

Now when I apply the brakes, rear defrost, blinkers, use the electric windows and fog lamps, my head lights and dash lights flash brighter briefly.

The car runs fine with no warning lights.

The alternator tests out fine, the battery tests out fine and I don't have any bad fuses. I am guessing I have a bad ground somewhere, but I am not an electrical wizard to search for it. Has anyone ran into this? Any direction, website or youtube video recommendation would be helpful.

Thanks
 

· Premium Member
Joined
·
23,154 Posts
It's normal on these cars.

You just may not have noticed the voltage fluctuation before if your alternator was weak. It's been discussed on the Forum since these cars first came out.
 

· Registered
Joined
·
659 Posts
Dealer tech and I were chasing some other electrical gremlins in my 06 SRT and he knew that the 08 had a recall for the ground cables on the battery/frame and engine/frame.
He ordered the ground kit for my 06 and after it was installed, the flickering and dimming/brightening of the lights was greatly reduced, still there, but much better.
IIRC it's a ~$70 kit, but he said since there was a recall he was able to get the kit for ~$20. He showed me the old and new cables, and there was a significant difference in the gauge of the wire used.
Might be something to check into.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top