Charger Forums banner

DESTROYED: Navigation DVD Hack ... Please Help =/

3474 Views 9 Replies 6 Participants Last post by  wrestlingnrj
Hey everyone -

I'm in desperate need of assistance and I am hoping that someone here has some answers.

I got the "hacked" version of the Navigation DVD for my 2006 Dodge Charger. In fact, I've had it for about 5 months now, and it's been working fine until recently.

Just last week, it's been giving me errors and I am unable to load the Navigation screen at all. Here is a screenshot of the error message:

What I've tried thus far:
Well, the only thing I have tried is inserting the original Nagivation disk. However, it then tells me something about "inserting a disk that has a different version".

I would really really really really appreciate anyones help.


- Chris
See less See more
1 - 4 of 10 Posts
I had that same problem with the disk I had burned, but I took it out and found that it was warped. I was able to use my AE disk though even though I upgraded to AF. I would try making another AF Hacked disc to see if that works.
I tried to burn the CD again but I am getting errors when copying the files. It seems like the disk is really messed up.

Can someone please help me?
Replied to PM, help is on the way.
The messages your getting is from a bad disk. The message about the wrong disc version is when you've updated the nav with a new disc and you try to use an older version. Once you update the nav, you have to keep using the same nav disc that you used to update.
Not completely true. I wanted to see what would happen if I stuck my factory AE Nav disc back in after updating with the In Motion AF version and it told me that it was an upgrade disc and would need to reboot. It did and never "updated" anything and works just fine, but still retaining full In Motion functionality.
Does anyone recommend a good brand of disc to use? I've tried several and that error message is still coming up..and i know they're good discs
Use Verbatim discs. So far I've tried: Memorex, Sony, TDK, Dynex, and a couple other off branders and the Verbatim are the only ones that haven't errored out for me.
1 - 4 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.