Charger Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
briefly:
06 Rt has been stalling since ignitionswitch was changed been to the dealer twice. first time the said it was the jet chip (NOT!) second time they said its the PCM (which one is correct?) ofcourse they want $1000 to fix it. I can get a programmed PCM for $289 and fix it myself. My question is what are the symptoms of a bad PCM because the only thing that has happened its the car stalling, no engine lights, nothing.
 

·
Premium Member
Joined
·
11,698 Posts
First, take the jet chip and find the nearest lake to throw it into.

Then, pull off the battery cable for at least 1/2 hour.

If that doesn't fix it, find another dealer.

Why was the ignition replaced?
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #3 ·
The actuator pin inside the ignition cylinder broke. So that and the ignitionswitch was changed. The jet chip was taken out lastweek. afterwards it still stalled. I had it towed home today but for some reason it has not stalled. I ordered a new PCM anyway
 

·
Premium Member
Joined
·
17,450 Posts
It might be the crank position sensor going bad. No codes, the PCM will simply lose where to fire the spark and it will stall.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 ·
It might be the crank position sensor going bad. No codes, the PCM will simply lose where to fire the spark and it will stall.
do you know where the crank position sensor is located? here is an update. The car has been starting and running like normal all today. i took it out drove it around, parked turned off started, drove and no problems. I already ordered a new PCM (smh) I just want the darn thing to run like its running now.
 

·
Premium Member
Joined
·
17,450 Posts
do you know where the crank position sensor is located? here is an update. The car has been starting and running like normal all today. i took it out drove it around, parked turned off started, drove and no problems. I already ordered a new PCM (smh) I just want the darn thing to run like its running now.
I'm not certain. It's on the back of the engine next to the tranny (passenger side I think) the pick-up is on the flywheel. I'm getting mine replaced in a few days due to a hard start issue when it's below freezing outside and the engine is hot. It loses the signal and can't figure out when to fire. It also has a stumble in the idle.

After they do it, I'll let you know the exact location.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #7 ·
I'm not certain. It's on the back of the engine next to the tranny (passenger side I think) the pick-up is on the flywheel. I'm getting mine replaced in a few days due to a hard start issue when it's below freezing outside and the engine is hot. It loses the signal and can't figure out when to fire. It also has a stumble in the idle.

After they do it, I'll let you know the exact location.
ok cool. im baffled because before i had it towed to dealer it was stalling every 5 seconds now its working fine. im not sure if its pcm or crank sensor or what. i have a huge headache dealing with this car. Im sure tmw if i take it out it will shut off.
 

·
Premium Member
Joined
·
17,450 Posts
ok cool. im baffled because before i had it towed to dealer it was stalling every 5 seconds now its working fine. im not sure if its pcm or crank sensor or what. i have a huge headache dealing with this car. Im sure tmw if i take it out it will shut off.
The behavior on mine is very sensitive to weather conditions and temperature. It's been slowly building over the past 2 years. It took me a long time to put the patterns together that indicate the source. I took it out a few days ago when it was 50*F and it showed no symptoms. Today it's 36 and it's showing them again. I can now predict almost exactly how it will behave based on the outside temp, humidity and engine temp.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #10 ·
wait.....is the jet chip still out of it?
yea it was taken out last week, since then it has stalled numerous times prompting me to have it towed to the deal. I got the car back today. they wanted $1000 to replace pcm so i declined it and had the car towed back to me. to my surprise i started it and it hasnt cut off yet
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #11 ·
The behavior on mine is very sensitive to weather conditions and temperature. It's been slowly building over the past 2 years. It took me a long time to put the patterns together that indicate the source. I took it out a few days ago when it was 50*F and it showed no symptoms. Today it's 36 and it's showing them again. I can now predict almost exactly how it will behave based on the outside temp, humidity and engine temp.
that is crazy. that is why its important to learn your car because most of the stuff leading up to now i fixed myself. hopefully the pcm will fix my prob since i already ordered it. if not ill just have to keep trying to pinpoint the prob (which the stealership failed to do)
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #13 ·
updates???

well after all that I took it to another dealer and they replaced the PCM. I thought it wasnt the PCM because I had bought one online. They found out that the pcm i bought was programmed with two VIN # (dont ask me how lol) so after they replaced it everything is back to normal. O2 sensors work and no stalling; however because I went so long without the 02s im getting catalytic code P0430. hopefully I wont have to get new cats but otherwise it runs great.
 

·
Premium Member
Joined
·
11,698 Posts
well after all that I took it to another dealer and they replaced the PCM. I thought it wasnt the PCM because I had bought one online. They found out that the pcm i bought was programmed with two VIN # (dont ask me how lol) so after they replaced it everything is back to normal. O2 sensors work and no stalling; however because I went so long without the 02s im getting catalytic code P0430. hopefully I wont have to get new cats but otherwise it runs great.
Clear the codes with diablo or any auto parts store can do it. So will disconnecting the battery. If it continues to throw a code, spark plug anti fouler will solve the problem :)
 

·
Registered
Joined
·
22 Posts
Yea I want to know some probable causes for the pcm to go bad. Where did you buy yours from? I may need one as well but mine starts and stals right away with ebs light on and red bolt flashing. .gas pedal won't do Anything and break is hard to push down on. .
 
1 - 16 of 16 Posts
Top