Charger Forums banner
1 - 20 of 21 Posts

·
Premium Member
Joined
·
607 Posts
Discussion Starter · #1 ·
I just noticed on my 2007 Police Charger, when I engage Cruise Control, the amber light on the multi control lever lights up, I get the cruise symbol and "CRUISE" in the instrument panel.
On my 2006 Daytona with EVIC, all I get is the amber on light on the switch lever. The cruise is working fine, just no display anywhere in cluster. Can someone with an 06 with EVIC tell me if you get a display when cruise is activated , and if so, where in the cluster...???
 

·
Premium Member
Joined
·
15,199 Posts
Hmmm, my SRT-8 displays the cruise symbol, right side, that speedo looking thing with the arrow at about 10-11 o'clock, and the EVIC shows "Cruise Set" when I set the speed.

Might also say "Cruise On" when its on, but not set, but I'm not %100 on that.
 

·
Premium Member
Joined
·
607 Posts
Discussion Starter · #3 ·
OK. My Police shows the Symbol above the gear selection on the right. "Cruise" and "Set" on left. I guess then the EVIC would be in the same place. I just never noticed until I got the Police. I guess it's time for trip to dealer. Thanks for the quick response...
 

·
Premium Member
Joined
·
607 Posts
Discussion Starter · #4 ·
06 Daytona Owner Help...

OK, So now I'm really confused. The PDF Owners manual mentions the symbol and "Cruise" will illuminate in the instrument cluster. I just checked my owner's manual in the car, and it only mentions the control lever will illuminate when cruise is active... Can some one with an 06 Daytona with EVIC (My build date is 08/05) tell me if you get any display in the instrument cluster when cruise is on, or do you just get the amber light on the lever.
 

·
Registered
Joined
·
4,228 Posts
Hi ,I get a message on my dash, cruise set,plus the light on the stalk.My date is 3/06 . JIM
I don't have that on my GMG Daytona. I just have the light on the stalk. My build date is Aug 2005. I guess thats another mid-year change.
 

·
Premium Member
Joined
·
607 Posts
Discussion Starter · #7 ·
I don't have that on my GMG Daytona. I just have the light on the stalk. My build date is Aug 2005. I guess thats another mid-year change.
Thanks moparknighthawk, thats exactly what I'm looking for. Our build dates are the same and we don't have it. Wonder if a software update would give it to us ???
 

·
Premium Member
Joined
·
607 Posts
Discussion Starter · #8 ·
Moparknighthawk, just got off the phone with service manager. He told me to keep my appointment and he will try a software update. I'll post back if it works...
 

·
Registered
Joined
·
4,228 Posts
Moparknighthawk, just got off the phone with service manager. He told me to keep my appointment and he will try a software update. I'll post back if it works...
Ok, thanks. :grin:
 

·
Registered
Joined
·
3,160 Posts
i dont have it either. only the light thats on the cruise control stick.

mangozilla... how do u get a flash with the new software? does this mean u can also get the 0-60 timer??
 

·
Premium Member
Joined
·
7,632 Posts
RT w/ R&T, build date 8/05. When I got the car, only the amber light on the stalk indicated anything about cruise. At a local M&G, someone had a StarScan and upgraded the software in all my modules. Now I also get an EVIC display. I'd say the dealer should be able to do it, too, if properly motivated.
 

·
Premium Member
Joined
·
607 Posts
Discussion Starter · #13 ·
RT w/ R&T, build date 8/05. When I got the car, only the amber light on the stalk indicated anything about cruise. At a local M&G, someone had a StarScan and upgraded the software in all my modules. Now I also get an EVIC display. I'd say the dealer should be able to do it, too, if properly motivated.
Hey mnues, that's great to know. Service Manager at local dealer told me he would try. I'll give him this info. Thanks. I'll post after appointment Tuesday....
 

·
Registered
Joined
·
122 Posts
Hi goMango259. Asked dealer to update dash to highest available for my car and v4.08 was it. It didn't come with 0 to 60 timer or mds indicator. It also came with the ability to adj auto on senestivity for my lights. Hope this helps. Jim
 

·
Registered
Joined
·
3,126 Posts
My Torred shows "Cruise On" when I turn it on as well as the cruise control icon. When I set the speed I want it'll say "Speed Set" where the odometer is.
 

·
Registered
Joined
·
624 Posts
RT w/ R&T, build date 8/05. When I got the car, only the amber light on the stalk indicated anything about cruise. At a local M&G, someone had a StarScan and upgraded the software in all my modules. Now I also get an EVIC display. I'd say the dealer should be able to do it, too, if properly motivated.
What version are you now showing on the EVIC? Any other "tweeks" to EVIC that showed up with that upload worth mentioning??

I believe I am also 8/05 build and do not get anything in cluster when activating cruise.
 

·
Premium Member
Joined
·
7,632 Posts
What version are you now showing on the EVIC? Any other "tweeks" to EVIC that showed up with that upload worth mentioning??

I believe I am also 8/05 build and do not get anything in cluster when activating cruise.
CCN P/N 56044947AE
10/25/05 v4.08

I can now adjust the auto-headlights trigger (how dark it has to be for auto-headlights to turn on/off) as well as the cruise control indicator. I don't recall any other noticeable changes.
 

·
Registered
Joined
·
3,160 Posts
thanks for the replies mnunes and mangozilla. i'll have to stop by and see if they can update me. i guess i'll ask for the tcm reflash while i'm in there as well :grin:
 

·
Premium Member
Joined
·
607 Posts
Discussion Starter · #19 ·
Cluster & TCM Update.

thanks for the replies mnunes and mangozilla. i'll have to stop by and see if they can update me. i guess i'll ask for the tcm reflash while i'm in there as well :grin:
I took my Mango in today. They did the Cluster update from v4.05 to v4.08 # 68000247AA.That got me Cruise display in cluster. I also asked for the TCM Flash. He found the following update, and flashed # 4692392AK. This is not the same as others have posted for the SRT Flash, which is 04275086AB. The drive after Flash was definately firmer 1st to 2nd. I have not heard mention of this flash on here before. Anyone else ??
 

·
Premium Member
Joined
·
7,632 Posts
I took my Mango in today. They did the Cluster update from v4.05 to v4.08 # 68000247AA.That got me Cruise display in cluster. I also asked for the TCM Flash. He found the following update, and flashed # 4692392AK. This is not the same as others have posted for the SRT Flash, which is 04275086AB. The drive after Flash was definately firmer 1st to 2nd. I have not heard mention of this flash on here before. Anyone else ??
I also got my TCM flashed up to 46932392AK v1.03. That must be what goes in the RTs. Same experience as you with the firmer 1>2 shift. :)
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top