Charger Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have an '07 SXT. It has 146,000km's, and just recently the code P1004 appeared when I read the diagnostic. Cleared it, and now the wiper motor stays on constantly, and the CEL came on again.
I am scheduled to take the car to my mechanic tomorrow, but is there any connection between the two? ( I had to pull the wiper fuse to stop it).
Thanks,
ps- I will check the code again this evening an leave it for the mechanic to decipher.
 

·
Registered
Joined
·
584 Posts
I have an '07 SXT. It has 146,000km's, and just recently the code P1004 appeared when I read the diagnostic. Cleared it, and now the wiper motor stays on constantly, and the CEL came on again.
I am scheduled to take the car to my mechanic tomorrow, but is there any connection between the two? ( I had to pull the wiper fuse to stop it).
Thanks,
ps- I will check the code again this evening an leave it for the mechanic to decipher.
The P1004 refers to the sensor for something or other... i had to have mine replaced to get my error to stop. took 2 trips to the dealer before they replaced the right part. it is in the picture i took below. i posted it a long time ago, but here it is again. There are two of them, i am pointing to one of them in the picture. The service guy showed me it after he replaced it.




hope that helps. it shouldn't affect your wipers though....
 

·
Registered
Joined
·
14,728 Posts
:no: nothing to do with the wipers at all. that piece being pointed at is a runner control solenoid
 
1 - 3 of 3 Posts
Top