Charger Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
850 Posts
Discussion Starter #1
On my 06 SXT:

Driving down highway today with my headlights on listening to the radio. All of a sudden the light on the instrument panel (backlight) goes out. Im staring at it and after a few seconds all of the check lights come on, every one of them. My stereo shuts off for a second then comes back on and my check lights all reset. The headlights still work but rhe backlight does not. My guages were stuck so I did the cluster reset but my speedo is still stuck.

Wth??! Any ideas?


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
7,632 Posts
I've heard a number of theories on this one, but I don't recall any one specific fix being declared "the one"
- bad connection to the instrument cluster
- bad ground at the instrument cluster
- bad ground in the engine compartment by the fuse block
- bad ground under the dash
- bad ignition switch
 

·
Premium Member
Joined
·
17,450 Posts
It's possible, but not likely. It may be the extra power coming through the cluster connector from the back light being on.

If it doesn't do it with the lights off, it sounds like something in the instrument cluster power connections. It may as simple as condensation in a loose main connector. Especially since it started when the weather warmed a bit.
 

·
Premium Member
Joined
·
7,632 Posts
Can it be related to the light switch? I noticed today that i never does any of this in the day with my lights off. Only when the lights are on does it spaz out.


Sent from AutoGuide.com Free App
Did you ever try completely disconnecting the headlight switch? With the switch disconnected the headlights will be on any time the ignition is on. This might indicate whether there's a power issue (you'd still have the problem) or if it's related to the headlight switch (likely a bad dimmer).
 
1 - 11 of 11 Posts
Top