Charger Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
2,200 Posts
Discussion Starter · #1 · (Edited)
So I got caught up on a few mods today, mainly NOESP (woot! that's fun!) and a combination Auto Coolit and new Tstat. I used a Stant 170 degree, forgot to take a photo of the Tstat itself, but have one of the box:grin: . It is a 64mm diameter, but actually went in fairly easily, to my surprise. I did spend a lot of time reading Meisters goldmine of info on this topic.

Installation went well, but I wanted to share this with you (see pics). When I bought the new Tstat, I saw a sign in the store that said "replace your thermostat every 60,000 km (or 36,000 miles for our american friends). Mine just rolled over 59,000 km, so I thought to myself "My, that's very timely then!"

But I was still surprised to see the condition of the OEM Tstat when I removed it - it was in two pieces, and the rubber ring over the faceplate (not the sealing gasket) was shredded.

So indeed, seems like I caught his just in time, although I have to say the car seemed to be working normally. I've been monitoring the tempereature with EVIC for the last week so I could see the difference after installing the Coolit/new Tstat. Temps were hovering around 205-210 degrees before the mods. With the mods, and Coolit default settings, it is running between 176-185 degrees.

So, even if you do not want to use a different Tstat, check and replace yours anyway, especially if mileage is getting up there. It was a very simple job to replace mine, and I am no mechanic. Just followed the instructions posted here and on lxforums.com
 

Attachments

·
Registered
Joined
·
529 Posts
Maybe poor quality product DC is using. Isn't stant also the stocker?
 

·
Registered
Joined
·
331 Posts
I had the same Problem on my 300. Dealer replaced it because car wasn't going past 1/4 on the temp gauge, they found the T-Stat in 2 pieces! Car had 30k miles.
 

·
Registered
Joined
·
246 Posts

·
Registered
Joined
·
1,440 Posts
It's actually an incriminate of measurement. Red being the most precise
Actually red is between Burnette and Blond.... slighty heavier than a Strawberry blonde, not quit as fine as a "true" blond......
 

·
Registered
Joined
·
300 Posts
If anyone's interested in a Coolit fan mod, I lowered the price for December.

The Auto version is now $99 shipped (was $150)

The Manual version, perfect for track use for Diablo users is now $59 (was $75)

I have both in stock.

secret link to lower prices: www.noesp.com/sale.html
 

·
Registered
Joined
·
163 Posts
I'm now near 73,000 km and today temps had a hard time going over 1/4 of gauge. I guess it's time for replacement.

At least now i know why it took so long to reach it's running temp.
 

·
Premium Member
Joined
·
8,140 Posts
That is crazy, seems pretty low in miles to see that kind of failure. I wonder if I will need to keep an eye on my Napa 180 t-stat
 

·
Registered
Joined
·
163 Posts
You should have popped a code and chime for this failure.
No code or chime just take a bunch of time reach temp. Trip to work is about 20 miles and when i got there tonight temp was at 176F, got to 206F on my way back to home.

I'll swap it for 180F
 

·
Registered
Joined
·
2,069 Posts
Normally, if the PCM doesn't see the engine temps reach operating parameters within a specific time, you get the "ding". Guess you are right on the edge of being OK.
 

·
Registered
Joined
·
6,078 Posts
Has anyone with a V6 had this issue with their thermostat? I have over 52k on my SXT. Should I look into this, too?
 

·
Registered
Joined
·
325 Posts
I installed a 4128 180 deg. t-stat about 5 months ago and it is now stuck open, gonna have to replace it this weekend. What a drag.:angry:
 

·
Registered
Joined
·
771 Posts
Shouldn't this kind of failure be corrected under warranty... Or do I smell a TSB perhaps???

I can't explain the separation of the T-Stat, but the shredding of the gasket probably happened when it was installed or removed.

I also wonder for those who had the coolant flush TSB (like me), if the dealer put in a new T-Stat then or just left the old one in the radiator housing??
 
1 - 20 of 23 Posts
Top