Charger Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey y'all.
So I was driving this morning on my way to work, when the check engine light, and the little lightening bolt cell turned on on my dash. I pulled over and turned the car off to throw my reader on but it did not show any codes. When I went to restart the car it almost wouldn't start. Had to crank it a little while and give it some gas like you would an older vehicle. I was thinking starter or alternator possibly? It has always had a strong start on the first start of the day, but when it gets warmed up and you try and start it the starter struggles. In ideas where to begin? If I can do this repair myself I would like too, it's been in the shop so much lately I'm starting to get discouraged on ever making upgrades cause I spend so much just keeping her on the road
 

·
Registered
2013 R/T
Joined
·
2,328 Posts
Why would you not include the year model, engine, and mileage? Or what code reader you have.
 
  • Like
Reactions: 79jasper and N8ECH

·
Registered
Joined
·
2,329 Posts
Hey y'all.
So I was driving this morning on my way to work, when the check engine light, and the little lightening bolt cell turned on on my dash. I pulled over and turned the car off to throw my reader on but it did not show any codes. When I went to restart the car it almost wouldn't start. Had to crank it a little while and give it some gas like you would an older vehicle. I was thinking starter or alternator possibly? It has always had a strong start on the first start of the day, but when it gets warmed up and you try and start it the starter struggles. In ideas where to begin? If I can do this repair myself I would like too, it's been in the shop so much lately I'm starting to get discouraged on ever making upgrades cause I spend so much just keeping her on the road
You need an advanced scantool that can read Pending, Network, Body, and Powertrain codes.

You don't have a 2.5, you've either got a 2.7 or a 3.5.
 

·
Registered
2013 R/T
Joined
·
2,328 Posts
Been in the shop lots eh? I know if I disconnect my throttle body on my 2013 R/T, say to get it out of the way to work on something else I get the ETC lightning bolt (electronic throttle control) and hard start rough idle. I disconnect the battery for a minute and restart & shes all good. I avoid that cable now.

Could be other stuff though.
 

·
Registered
Joined
·
5 Posts
I got a used airflow sensor and the hesitation is gone but the engine light is still comming on when going down the highway. I may put in 2 new O2 sensors I had one melted cat and I think they are the orignal ones. The car is running a bit rich. Also do the throttle position sensors go bad?
 
1 - 6 of 6 Posts
Top