Charger Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter · #1 ·
Hello to all, I took my 07 srt8 to the dealership today to fix have my tire fixed. i had a screw in it, so i figured i will have the oil changed. When i went to pick up my car, the service guy asked how long my check engine has been on. i told him never. so now my check engine light is on. do you guys think it has soemthing to do with my programmer. when i get home i will look for codes. any ideas would help. thanks to all....
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #3 ·
i will go out and do the key trick.... no the dealer didnot see ehat the code is... they just said the light was on.... once i get the code where can i find out what it is
 

·
Registered
Joined
·
3,098 Posts
i will go out and do the key trick.... no the dealer didnot see ehat the code is... they just said the light was on.... once i get the code where can i find out what it is
you mean to say you were at the dealer THE DEALER and a code showed and they didnt tell you what was wrong?

I would go back to that dealer and make them explain what the deal was.
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #5 ·
i tried the key an nothing happened.... no code...... i will wait till i get home and see what the diablo says
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #6 ·
they did not hook it up to find out what was wrong. they thought i new about it. i hope they did not do something to screw up my programming. all thay did was fix a flat and change the oil. what could thy have done to have the check engine light come on.
 

·
Registered
Joined
·
1,828 Posts
they did not hook it up to find out what was wrong. they thought i new about it. i hope they did not do something to screw up my programming. all thay did was fix a flat and change the oil. what could thy have done to have the check engine light come on.
They should have done it right then and there. I would be calling the service manager and complain its redicoulus that the dealer would let the car go with the check engine light on unless you wanted to take your car home and didn't want them to look at it cause you still had you diablo program on it?....
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #8 ·
thay called me and said it was done so i said i will be there on my lunch break and as i was paying for the service is when they told me about the light. so i ok. so i will go home and see what it is and take it from there. i am hoping it is something stupid. i will not go back to that dealership.
 

·
Registered
Joined
·
1,828 Posts
Hmmm well if you didn't do anything to your car and you loaded the original settings why wouldn't you take it back?
 

·
Registered
Joined
·
3,098 Posts
thay called me and said it was done so i said i will be there on my lunch break and as i was paying for the service is when they told me about the light. so i ok. so i will go home and see what it is and take it from there. i am hoping it is something stupid. i will not go back to that dealership.

it takes all of five min to hook up and read the codes from the car.... they could have done that. you just had a lazy arse tech working on your car.
hope they did the oil change right.
hmm not sure about our cars but it used to be stanard practice where ever you took your car in for an lube/oil change they check all the fluids. to check the trans fluid on the charger you need a starscan. that reads codes too...


make sure you did the key trick right to get the codes.
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #11 ·
Hmmm well if you didn't do anything to your car and you loaded the original settings why wouldn't you take it back?
2 reasons, they waited till the i was paying to tell me about the light, when they could have told me on the phone. and how do u go in for an oil change and have a light come on.
 

·
Registered
Joined
·
1,828 Posts
it takes all of five min to hook up and read the codes from the car.... they could have done that. you just had a lazy arse tech working on your car.
hope they did the oil change right.
hmm not sure about our cars but it used to be stanard practice where ever you took your car in for an lube/oil change they check all the fluids. to check the trans fluid on the charger you need a starscan. that reads codes too...


make sure you did the key trick right to get the codes.
Hey sometimes the code won't pop up and will only have ------ unless thats a code which I really doubt. One while I was driving my RT my tranny went into limp mode it scared the $h!t out of me, I did the key thing and nothing would pop up, and yes my light was still on. It turned out that the same day I was going to take my car to the dealer the light turned off by itself.
 

·
Registered
Joined
·
1,828 Posts
2 reasons, they waited till the i was paying to tell me about the light, when they could have told me on the phone. and how do u go in for an oil change and have a light come on.
Hehehe, I guess. Well then take it to another dealership, hopefully there is more then one in your area and not kie 75 miles away good luck.
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #14 ·
the tech looked about 17 years old. on my invoice it said they added 7 quarts of oil at $10 a quart.
 

·
Registered
Joined
·
3,098 Posts
the tech looked about 17 years old. on my invoice it said they added 7 quarts of oil at $10 a quart.
little high for mobil 1 but not too bad.
it is a dealer after all

for oil changes they have the interns or junior guys do them since it should be a NO brainer job.
 

·
Registered
Joined
·
1,828 Posts
little high for mobil 1 but not too bad.
it is a dealer after all

for oil changes they have the interns or junior guys do them since it should be a NO brainer job.
Yeah until one of them forget to completely tighten the oil drain bolt, can you say seized block.
 

·
Registered
Joined
·
243 Posts
The engine light came on for me once after I reinstalled My CAI for no apparent reason so I unhooked the negative battery terminal for a minute and its been clear for 1000miles with no trouble codes on predator!:lol:
 

·
Registered
Joined
·
1,828 Posts
The engine light came on for me once after I reinstalled My CAI for no apparent reason so I unhooked the negative battery terminal for a minute and its been clear for 1000miles with no trouble codes on predator!:lol:
Hopefully you at least tried to find out what the code was before reseting it.
 
1 - 19 of 19 Posts
Top