Charger Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
This morning my CEL came on for the 3rd time in a month. Last time I took it in they replaced the O2 sensor and it seem to fix it. That was about 3 weeks ago. I will take it in to the dealer (Folsom Lake Dodge) tonight and leave it with them over the weekend and see what they say this time. I hope this doesn't turn into one of those nightmare mysterious CEL issues that I have read about in other threads on several forums.

I am starting to lose my love for this car. :(
 

·
Registered
Joined
·
498 Posts
You are not alone here...I am having the same problem. It came on (again) a few days ago after being at the shop for 5 days. They replaced the sensor and told me if it came back on tho bring it back and leave it with them. Well, this morning I go out, start it up and poof, no CEL? I am as confused about this as you are.
 

·
Registered
Joined
·
2,069 Posts
You are not alone here...I am having the same problem. It came on (again) a few days ago after being at the shop for 5 days. They replaced the sensor and told me if it came back on tho bring it back and leave it with them. Well, this morning I go out, start it up and poof, no CEL? I am as confused about this as you are.
CEL will clear itself after a few drive cycles if there are no more hick-ups. Post up the code stored, it might help pin point a cause.

But having a 180 t-stat and LTH, I think one can expect a CEL to pop up every once in a while.
 

·
Registered
Joined
·
498 Posts
CEL will clear itself after a few drive cycles if there are no more hick-ups. Post up the code stored, it might help pin point a cause.

But having a 180 t-stat and LTH, I think one can expect a CEL to pop up every once in a while.
Thats what I was afraid of....however that shouldn't make the car stall and run rough should it? It didn't do that since I got it back, but it was before going in.
 

·
Registered
Joined
·
358 Posts
hal monitors like 1000 different sensors. there is a back up sensor for every sensor in our cars. I heard from my service advisor that it is usually a bad o2 sensor that the cars on board diagnostic is picking up. it is also true that if the cel comes on that it saw a problem that the computer was able to fix, or the problem did not continue. the cel will turn itself off again.
 

·
Registered
Joined
·
2 Posts
This morning my CEL came on for the 3rd time in a month. Last time I took it in they replaced the O2 sensor and it seem to fix it. That was about 3 weeks ago. I will take it in to the dealer (Folsom Lake Dodge) tonight and leave it with them over the weekend and see what they say this time. I hope this doesn't turn into one of those nightmare mysterious CEL issues that I have read about in other threads on several forums.

I am starting to lose my love for this car. :(
Mob muscle , I've had the same problem with mine also. But my car went in limp mode just before the cel came on My charger has been to the dealer 3 times for the cel. The first time they only changed 1 O2 sensor,Then I had to go back and they changed all the sensors. And a day later the cel was back on again. So back to the dealer. Not to mention every time they looked at my car,they sent me home saying they will call me when the part was in. The last time back in they had to order a catalytic converter. It has been 1 month and no cel light. I think that did the trick--------cross my fingers
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #7 ·
Mob muscle , I've had the same problem with mine also. But my car went in limp mode just before the cel came on My charger has been to the dealer 3 times for the cel. The first time they only changed 1 O2 sensor,Then I had to go back and they changed all the sensors. And a day later the cel was back on again. So back to the dealer. Not to mention every time they looked at my car,they sent me home saying they will call me when the part was in. The last time back in they had to order a catalytic converter. It has been 1 month and no cel light. I think that did the trick--------cross my fingers
I hope it is something simple. The difference is that I have not not noticed any problems with the way the car runs. It is smooth as silk and running strong. So, it may not be the same issue. Thanks for the heads up.
 

·
Registered
Joined
·
2,069 Posts
hal monitors like 1000 different sensors. there is a back up sensor for every sensor in our cars. I heard from my service advisor that it is usually a bad o2 sensor that the cars on board diagnostic is picking up. it is also true that if the cel comes on that it saw a problem that the computer was able to fix, or the problem did not continue. the cel will turn itself off again.
1000 sensors....nope, there are no "back-up" or redundant sensors and HAL does not fix anything.

The CEL will clear itself after a few drive cycles, if the offending problem doesn't appear again.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top