Charger Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
2012 charger srt8 6.4.
So i replaced the water pump and put new 180 degree Tstat.
Added new coolant.
Found small leak on lower hose attached to the water pump. Gonna fix that tomorrow...My SRT gauges showing coolant temperature was at 226. Also transmission at 226. Oil temp was at 201. Oil pressure was at 18-25. All this was while idling. Any Ideas on what else may be
 

·
Registered
Joined
·
2,204 Posts
2012 charger srt8 6.4.
So i replaced the water pump and put new 180 degree Tstat.
Added new coolant.
Found small leak on lower hose attached to the water pump. Gonna fix that tomorrow...My SRT gauges showing coolant temperature was at 226. Also transmission at 226. Oil temp was at 201. Oil pressure was at 18-25. All this was while idling. Any Ideas on what else may be
You have to adjust your fan speeds with a handheld tuner to correlate with the lower temp thermostat. Stock the high speed fans don't kick in until 217F, so seeing 226 idling isn't unheard of.

The oil temp is normal, and the trans temp is as well. The trans has a bypass that doesn't open until 195-205F, and generally matches the coolant temp.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
You have to adjust your fan speeds with a handheld tuner to correlate with the lower temp thermostat. Stock the high speed fans don't kick in until 217F, so seeing 226 idling isn't unheard of.

The oil temp is normal, and the trans temp is as well. The trans has a bypass that doesn't open until 195-205F, and generally matches the coolant temp.
I have a diablotuner on my 15 challenger. That should work 🤔 if it's just plug & play
 

·
Registered
2013 R/T
Joined
·
2,591 Posts
Or just go back to the OE T-Stat. At full operating temps they are all the same = Fully Open.
I'm thinking you have dual fans. Just to be sure both fans are running you have to look, and use a flashlight. A motor could be locked and it still kind of sound like both are running. It will not toss a code unless the relay fails.
The motors are easy to swap. The fan nut is left handed.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
Or just go back to the OE T-Stat. At full operating temps they are all the same = Fully Open.
I'm thinking you have dual fans. Just to be sure both fans are running you have to look, and use a flashlight. A motor could be locked and it still kind of sound like both are running. It will not toss a code unless the relay fails.
The motors are easy to swap. The fan nut is left handed.
Yeah both fans turn on
 

·
Registered
2011 Charger Pursuit
Joined
·
1,691 Posts
You have to adjust your fan speeds with a handheld tuner to correlate with the lower temp thermostat. Stock the high speed fans don't kick in until 217F, so seeing 226 idling isn't unheard of.

The oil temp is normal, and the trans temp is as well. The trans has a bypass that doesn't open until 195-205F, and generally matches the coolant temp.

Little late, but from the NAG1 one stuff I've seen the inline T-stat starts opening at the 160* range and is fully open around 185*.






Your Trans temps were 226 because you were in park or N I bet. Need to be in a gear to see accurate Trans Temps.

You may need to bleed more air out of the system as the car should be able to shed heat idling at the 217 low fan mark. I know My Pursuit isn't a 6.4, but with dual fans and the original thin radiator it had no issues staying below 217.
 
  • Like
Reactions: Punisher69
1 - 11 of 11 Posts
Top