Charger Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
377 Posts
Discussion Starter #1 (Edited)
Well I joined the ranks of breaking the the plastic piece on the air flow sensor and the clip on the plug that holds the connector on to the sensor. Came off without a hitch. Got it on to, but didn't like the way the grommet was pushed in so tried to take it apart. Gotta love it. May buy new sensor not sure yet. Anyone buy one? Used gorilla glue on the harness plug. Hope it holds.

On another note. Anyone every stick their hand in the hole below the CAI filter?? I noticed a harness down there that was not plugged into anything. Hmmmm. :knockout:
 

·
Registered
Joined
·
1,168 Posts
Broke mine months ago when I installed my CAI. Pushed it back in and went to Dodge to buy a new one ($20 or so). My "broken" one has never backed out again, so I'll just hang on to the new one for a while longer. Too lazy to go take it back and, if I did, it would probably fail the next day anyway....
 

·
Registered
Joined
·
916 Posts
I put mine on last week, after reading about everyone's bad luck with the sensor I modified it a bit. Take a dremel and the round sanding bit and open the hole just a bit bigger. Then push the grommit in and put a little dielectric grease on the sensor and she pops right in.

Good Luck!
 

·
Registered
Joined
·
877 Posts
I did the same thing with mine. The red clip that holds the sensor in place popped off and I could not find it anywhere. Called the dealership and they said I would have to buy a whole new wiring harness. Has anyone been able to purchase just the clip?
 

·
Registered
Joined
·
877 Posts
What does that 20$ consist of? The whole wiring harness that plugs into the sensor?
 

·
Registered
Joined
·
1,168 Posts
Yep, the whole wiring harness that plugs into the sensor and the trail of wires leading to out of it. It's a big scam, I say.
 

·
Registered
Joined
·
877 Posts
Yeah I heard that. Was u able to install it yourself or did they charge you to do that as well?
 

·
Registered
Joined
·
1,168 Posts
I ended up not using it yet. My "broken" piece is hangin' on just fine. It's been that way for a few months now, so I'm not too worried about it. I held on to the damn thing anyway. Basically like a $20 insurance policy. I probably replace it when I absolutely have nothing else to do (whenever that is).
 

·
Registered
Joined
·
377 Posts
Discussion Starter #10
Well I found the red clip, but broke the black piece off. Found the black piece and glued it on. I usd the red clip kinda like a vise to hold the black piece on while its glued. For $20 I may uy the new harness. I also broke the black cover on the sensor itself. I think I broke just about every piece you could. I need to buy everything just incase.
 
1 - 10 of 10 Posts
Top