Charger Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1 (Edited)
Ok...I have been able to burn out with EASE in any other vehicle (even vehicles that you really shouldn't be)...
The first time in the Charger and I was like ...WHAT THE H#LL!?
Well I didn't really know anything about ESP and now I have been staying
on the forums attempting to become a Charger GURU.

Here is my problem right now...
Turn off ESP completely using Brikar's turn the key to start while rolling at 15mph. Go to do a brake stand and SOMETIMES the car won't go above 2K on the tach. It's almost like it is rev limiting, but how can it be at 2k?!
Now I am using autostick and putting into 1st.
Am I not braking right? Am I just a loser? :lol:
I just want to know if I am doing something wrong or is there is some other system "protecting me from me" that I don't know about.
Just trying to figure out if I am a retard or maybe I am just overlooking something.:knockout:

Also, someone mentioned a way to recalibrate throttle response.
One guy mentioned starscan, another EVIC. I don't have either of these.
So is the only other known way is to do the 15 second pedal deal and is this a confirmed way to have the throttle recalibrate?

Thanks fellas for all the help and feedback!
Billy
 

·
Registered
Joined
·
168 Posts
Tried exactly the same thing last night

Dog A$$ed Daytona! Did the key thing, got ESP & BAS lit up. Tried a power brake thing, fell on it's face both times. PS, Auto stick in 1.

Guess I'll pay the $50.00 and get NOESP
www.noesp.com
 

·
Registered
Joined
·
60 Posts
Discussion Starter #4
Hey Fellas,
I have already ordered NOESP. The problem is the ignition trick works for me.
I get the ESP/BAS and Mr.Squiggles lights, so ESP should be completely disabled at that point. So I don't need the switch though I am going to use it anyway.
 

·
Registered
Joined
·
571 Posts
I have the same thing of course as well. It has to do with our brakes, I'm quite sure of it. They're too powerful, and with the fat tires.. much too difficult. I'll tell you, when I have bald 245/45/20's it's NO problem, but now that I have stickey 275/45/20s if it's not the right pavement, there's not going to be very much spinning.

- Jamos
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
I have the same thing of course as well. It has to do with our brakes, I'm quite sure of it. They're too powerful, and with the fat tires.. much too difficult. I'll tell you, when I have bald 245/45/20's it's NO problem, but now that I have stickey 275/45/20s if it's not the right pavement, there's not going to be very much spinning.

- Jamos
Hey Jamos,
Yeah you are on the right about the grip of the wheels.
My RT doesn't like to break loose no matter how hard you punch it.
That is their purpose, STICK TO THE ROAD and honestly a tire
that doesn't stick well is not a good thing no matter how fun it might
be when trying to make smoke. So I am not complaining about the grip.

Now I went out for a spin just a little bit ago and this is what would happen.
Press hard on the brakes, mash the accelerator, let loose a little, Engine would rev, lots of smoke, then the RPM's JUST DROPPED. It never gets real high like, then DROP and then rev back up again, then DROP. I have never experienced anything like it, so I am a bit of a loss.
Like I said earlier, it's a lot like its REV limiting, but it never get's high enough for that. I guess I am just trying to figure it out.
So do you think the brakes are causing this?
I thought that was a possible reason, but I don't understand the RPM drop.
I am really ignorant as to what is happening!:alien:
 

·
Registered
Joined
·
60 Posts
Discussion Starter #7
Jamos is that your SRT in your signature?
It's an awesome shot!
Billy
 

·
Registered
Joined
·
60 Posts
Discussion Starter #8
Dog A$$ed Daytona! Did the key thing, got ESP & BAS lit up. Tried a power brake thing, fell on it's face both times. PS, Auto stick in 1.

Guess I'll pay the $50.00 and get NOESP
www.noesp.com
Hey Lime,
The NO ESP switch is supposed to do EXACTLY what we both did.
It turns on the ESP/BAS light and Mr. Squiggles which is suppose to mean ESP COMPLETELY OFF.
So for us both to have the same problem of lurching seems too coincidental.
Either we are both doing something wrong, or there is something else.
I can get'em to break loose, and smoke the entire block up, but that doesn't really matter to me as much as the FREAKY RPM DROP.
Any techs, gurus, or freakingly awesome LX owners ideas would be greatly APPRECIATED!!
 

·
Registered
Joined
·
184 Posts
Sounds like you are brake stalling the trany. Stock stall converter is around 2K RPM. I just installed a Mopar Performance converter and now I can get it to 2600.
NOESP mod will not help
 

·
Registered
Joined
·
60 Posts
Discussion Starter #10
Sounds like you are brake stalling the trany. Stock stall converter is around 2K RPM. I just installed a Mopar Performance converter and now I can get it to 2600.
NOESP mod will not help
That sounds like it could very well be it. So am I not braking right?
What is the advantage of having a higher stall point?

Thanks LQQKOUT for feedback!

Billy
 

·
Registered
Joined
·
928 Posts
its the computer messing with you, its very intrusive.

I dont know what it looks for but try this....

esp on OR off, put the car in neutral, push the gas hard.... notice that at about 2500 rpm your engine will cut out. Same thing is happening, its just more noticeable under load.

if you want to smoke em, turn off esp, push the break in A BIT, just enough so you dont move and roll on the throttle some. they should spin like its nothing, and once they start spinning dont mash the gas, just let them spin they will keep picking up speed quite nicely.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #12
its the computer messing with you, its very intrusive.

I dont know what it looks for but try this....

esp on OR off, put the car in neutral, push the gas hard.... notice that at about 2500 rpm your engine will cut out. Same thing is happening, its just more noticeable under load.

if you want to smoke em, turn off esp, push the break in A BIT, just enough so you dont move and roll on the throttle some. they should spin like its nothing, and once they start spinning dont mash the gas, just let them spin they will keep picking up speed quite nicely.
Thanks OSU!
I will try that later on tonight and see what happens.
THanks AGain!
 
1 - 12 of 12 Posts
Top